1

Devices in app only show IPv6 addresses

As per the title, when viewing devices in the app, only IPv6 addresses are shown. Obviously I'd much prefer to see the IPv4 addresses given I don't use IPv6 at all.

In addition I have a device hard wired to a meshed access point which doesn't show at all. Not a big deal but worth mentioning.

17replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello, 

    In regards to IPv6 addresses being shown, do you have IPv6 enabled? Lets check this and disable this if we can. The toggle is in Settings -> Advanced -> IPv6. 

    In regards to the hardwired device not showing up as connected to the network. What troubleshooting steps have you done so far? The first steps I would recommend is to check and see if a software update is available. Settings -> Software Updates. If, after updating or if you do not need to update, you are still experiencing this behavior try soft resetting your gateway eero. I have linked an article below to walk you through this process.

    https://support.eero.com/hc/en-us/articles/215473703-How-do-I-reset-my-eero-

    Thank you,

    James Wilcox

    eero Support

    Like
  • I don't actually have an option to turn off IPv6. I would imagine this is because I'm in bridged mode ? It's behind a firewall which also has IPv6 disabled.

    Like
    • PeteB 

      Ahhhhh. If your eero network is in bridge mode than it does not handle any of the ip assignments or routing information. This means that any reporting in the eero app may not be correct. The app is meant to work with the router function of the eero devices and since you have your eero network bridged it will not always report correct data because it is unable to contact the router portion of the eero for updates.

      James Wilcox

      eero Support

      Like
      • john
      • john
      • 3 wk ago
      • Reported - view

      James I have the same problem. After upgrade, the eero app is only reporting IPv6 addresses... when IPv6 is disabled on all my macs. What's the fix?

      Like
    • Hello john ,

      I think you might be experiencing something different, but lets check. Is your eero network in bridge mode? Do you have IPv6 enabled on your eero network?

      Like
      • john
      • john
      • 3 wk ago
      • Reported - view

      James yes it is in bridge mode. there is no option to enable / disable ipv6.

      Like
    • Hello john ,

      Gotcha. That is the problem. When the eero network is in bridge mode it does not assign IP addresses to your devices, your upstream router manages the network and the eeros end up acting like as mesh network extenders. So the reporting in the app may not always be correct since the eero is not managing the devices or the network. The only way to correct this is to take the eero network out of bridge mode.

      Like
      • john
      • john
      • 3 wk ago
      • Reported - view

      James this used to work just fine, though? I dont understand why you are reporting ipv6 when it is disabled on my network? (I use NAT).

      Like
    • Hello john ,

      You shouldn't be using the reporting in the app when the eero network is in bridge mode. It is not always accurate and will sometimes report devices incorrectly because it is not managing the network. It is passing all management of the devices, with the exception of connecting to the access points, to the upstream router. In order for the correct information to be displayed in the eero app you will need to take the eero network out of bridge mode and allow it to update it's connections with the devices. It will then assign ip addresses to those devices and manage those devices. 

      When eeros are placed into bridge mode a lot of features are disabled. You can review the article below to see what features are lost.

      https://support.eero.com/hc/en-us/articles/115000825206-What-advanced-features-do-I-lose-access-to-if-I-put-my-eeros-into-bridge-mode-

      Like
      • john
      • john
      • 3 wk ago
      • Reported - view

      James That's depressing to read... though nowhere in that article does it say that address reporting in the app will be incorrect...? I would note that I have had my eeros in bridge mode since the day I bought them 5 years ago. The app used to report the device and IPv4 address information just fine; now it doesn't. The change happened - I believe - earlier this year. This is definitely a bug and - more importantly - it's a pretty easy fix for eero. It has absolutely nothing to do with bridge mode (though yes, I understand you don't people using bridge mode ...so you are gradually eroding it's utility). How about you show a little support for those of us that were there for you in the early days when you were still a startup in SF?

      Like
    • Hello john ,

      I understand your frustration and I would be happy to look into this more for you if you would like. I'll send you a direct message with instructions on how to get an email to me and once that is done I'll look into this some more for you. 

      Like
  • Well that's perfectly sensible as it isn't the DHCP server but you'd think it could figure the IP addresses of traffic passing across it.

    Like
  • I'm stunned today to open my app and have the Eero crap app displaying IPV6 addresses in bridge configuration which isn't using IPV6 and never has.   I've never had this problem in many years using the app.  As usual, Eero regressing features regularly.

    Like 1
  • Ok, I've noticed this too after recent EERO updates.  My network is in bridge mode and I have a pfSense firewall providing DHCP services.  I can assure you ipV6 is disabled and the DHCP server only is serving ipV4 addresses.  All of my client devices on the EERo used to have ipv4 addresses and after one of the most recent upgrades, everything only shows a ipv6 address.  This is not a bug in my firewall, dhcp server, this is plain and simple a bug in eero.   if the eero can discern the chip supplier, Mac address, and ipv6 address (which it's likely getting link-local since ipv6 is explicitly turned off on my network and devices.  In fact, some of my devices like say my garage door openers don't even support ipv6, ( I called them) so there is no way.   Eero needs to fix this bug. 

     

    -russ

    Like 1
  • Further to the topic, all 80 plus of my devices were happily displaying ipv4 devices, eero upgraded and now they don't. I'm quite sure I didn't go re-configure or touch 80+ devices and the firewall in my network has been online without an upgrade for well over 100 days and this problem showed up in the last 30-45 days.. 

     

    VersionKernel PTIUptime

    VersionKernel PTIUptime

    2.4.5-RELEASE-p1 (amd64) 
    built on Tue Jun 02 17:51:17 EDT 2020 
    FreeBSD 11.3-STABLE 

    The system is on the latest version.

    Version information updated at Sun Feb 14 16:57:56 EST 2021   

    Enabled
    111 Days 07 Hours 36 Minutes 25 Seconds
    Like
  • I too see IPV6 addresses where I should see IPV4 addresses. I believe what eero is displaying are the ‘link-local’ addresses and, in my LAN, are irrelevant. Link-local addresses are generated by the devices and not your DHCP server. eero should not be reporting these addresses as they are not used in a network that is not configured for IPV6. A link-local address has a prefix of FE80: If that is what you are seeing, "In the Internet Protocol Version 6 (IPv6), the address block fe80::/10 has been reserved for link-local unicast addressing" eero needs to be fixed to display the IPV4 address when IPV6 is not enabled. 

    Like
  • IPv6 has site-local address that are derived from MAC addresses and will be unique.

    IPv6 also doesnt have any problem of private/public IPs as with IPv4.

    Finally, even for IPv4, your local (possibly private) IPs, accessible from inside the LAN will always be unique. They have to be, so that the router can send packets to the correct computer/device.

    MyCCPay Log In

    Like
Like1 Follow
  • 1 Likes
  • 3 wk agoLast active
  • 17Replies
  • 265Views
  • 7 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com