cannot connect epson wf 2860 to eero 6 pro wireless

When I run through the set up for my epson printer to connect wirelessly, the printer doesn't see my network ID.  I have turned off 5 GhZ and turn on legacy mode.  I have connected the printer through an ethernet cable on a different rooms eero and updated all software and firmware and it prints and scan just fine.

Need help please

5 replies

    • eero_support
    • 2 yrs ago
    • Reported - view

    Hello tanlee07 ,

    Thank you for listing out all of the troubleshooting that you have done. I would recommend that you give our support a phone call. The troubleshooting steps you have taken already should have allowed even a printer that can only connect to the 2.4GHz and WiFi 5 on the network. There could be something else outside of the eero that might be preventing the printer from connecting to the network. You stated you even tried connecting it via ethernet and it still did not work which is a big flag that it is most likely not the eero network here.

    I found a guide on Epson's website. Can you take a look at it and verify you followed these steps?


    Below is a link with all of our contact numbers. 


    • tanlee07
    • 2 yrs ago
    • Reported - view

    Figured out the issue.  Apparently my printer and another device didn't like the having an ' in the network ID.  example, I had my network ID as Jon's home and it couldn't recognize. and when I took the ' off, so the network ID is just Jons home, it was fine.  Weird.... anyways its fixed.

      • eero_support
      • 2 yrs ago
      • Reported - view

      Hello tanlee07 ,

      That is great to hear you were able to get this behavior resolved. If you need anything else in the future please feel free to reach out to us here on the Community or give our support lines a call. Also, thank you for sharing your resolution!

      • donwohlfarth
      • 10 mths ago
      • Reported - view


      thank you so much. I spent hours trying to figure out the issue, changed settings, rebooted everything so many times. You found the hack. It was the “‘,” who knew? Thank you tanlee 

    • Andrew69
    • 9 mths ago
    • Reported - view

    You can connect a printer to your eero network wirelessly or via Ethernet. To connect your printer via Ethernet, simply attach an Ethernet cable from your printer directly to the Ethernet port of any eero in your network.

Content aside

  • Status Answered
  • 9 mths agoLast active
  • 5Replies
  • 729Views
  • 4 Following