Mobile browsers not blocking filtered content

I have the Eero Pro 6 (3 pack) system. I am running into issues with browsers, in particular Chrome, on iOS and Android devices not blocking sites that are manually added or that should be part of the content filtering. Safari sometimes will display the blocked.eero.com page.

In Chrome I consistently have one of the following scenarios happen:

1) I get a "Site can't be reached" message (ERR_CONNECTION_FAILED).  I hit the reload button at the bottom of the page and the site loads fine.

2) I get the accessibility page for the website.  I click on any of the links and the full mobile page loads just fine.

3) The site comes up with no issues at all.

I did contact support, but was told that they have a large backlog of issues.  When I asked if it would be hours, days or weeks before hearing back, I was told sometime between hours and weeks as they are very busy.

I have kids and take their online safety very seriously.  Prior to Eero, I used Circle for all my parental controls.  It worked great.  Unfortunately hooking up Circle to the Eero system, topples my network (an issue for another post).  I don't want to go weeks without functioning parental controls. 

Anyone else experiencing the same thing?  If you are using Chrome on a mobile device, I recommend at least testing your parental controls / blocked sites. I luckily stumbled upon this and was able to verify by marking specific websites as blocked for the entire network.

I am considering putting the Eero devices into bridge mode and using my old network setup to control everything.  However, then I am losing out on what I thought I paid for with Eero.

Any thoughts would be appreciated.


3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello Dan,

    Thank you for bringing up issue that you are experiencing. I took a look through our knowledge base and found an article that may be helpful. When adding sites to your block list in the eero app it might not take effect immediately. This can be due to stored caching stored on the device or the network. Have you tested accessing these sites after clearing the cache and cookies on the browser? I have included the article below for you to review as well.


    Thank you,

    James Wilcox

    eero Support

      • Dan
      • Customer Experience is Key
      • Dan.3
      • 1 yr ago
      • Reported - view

      James Wilcox yes, I tried clearing cache/cookies and incognito mode. Also waited several hours. Nothing worked. 

      • Sieglock
      • Sieglock
      • 1 yr ago
      • Reported - view

      Dan - please ensure that you are on the latest version of our firmware (we saw a few edge cases where old firmware put networks in strange states with Chrome). Once you are on the newest firmware, toggle on and off a parental control or filter. If that doesn't work, please email me at mark@eero.com so that we can troubleshoot further.

Like Follow
  • 1 yr agoLast active
  • 3Replies
  • 155Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support