0

Bizzare behavior with eero. Random websites blocked with connection reset

So I am seeing some bizzare behavior with eero. I have a setup with one gateway and one beacon (pretty simple setup). After I updated to 3.18.1-7, suddenly random websites won't load. I am also unable to download any files! So far I have seen

 

  • Discord will not startup because it can't download updates
  • I am unable to download any files (skype, discord, android studio, etc.). It all fails with "Network Error"
  • I can't visit websites like icloud.com or linkedin.com. Inspecting the site, looks like the javascript has failed to download with ERR_CONNECTION_RESET. The same error for discord!!

 

Steps I have taken so far

  1. I know this is a problem with eero because I connected directly to the model and everything works
  2. I know that my networking is not an issue because if I connect to VPN.. everything works
  3. I tried restarting the eero
  4. I tried resetting my network
  5. I have all eero Labs feature turned off

Looks like eero is blocking some random downloads (js, exe). I have eero Secure, but I have it turned off. 

I am at my wits end on how to fix this!! I have to throw my eero in the trash if this doesn't get resolved soon. 

 

     

11replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • You really need to contact eero support for this issue. I’m sure they’ll be able to get this resolved for you.

    Like 2
  • Yes I did. Wanted to see if anyone here also saw similar issues after the new update.

    Like 1
  • For those interested, eero has issues with SB6183 modem (which is what I have)

    https://support.eero.com/hc/en-us/articles/209384066-I-have-an-Arris-SB6183-modem-and-I-m-experiencing-issues-with-my-eero-network-

    However, it looks like there is another firmware version which also has similar bugs. I am running SB6183-9.2.0.0-GA-04-37-NOSH on the modem. So if anyone else is running this firmware, file downloads are affected (and random javascript files won't load)

    On this whole issue, eero support has been fantastic :) They have been very helpful and I am in the process of looking into how I can resolve this issue (maybe Arris can push a new update, or I probably would have to buy a different modem). Netgear CM600 seems to be a popular choice in the forums.

    Like 1
  • Running this FW version on my SB6183 without issues for what it's worth: D30CM-OSPREY-1.5.2.5-GA-00-NOSH. We're at the mercy of the ISP when it comes to modem firmware though.

    Like
  • David S I wish I could update my modem firmware manually. Apparently, only the ISP can do that. So I am probably stuck with the current firmware (unless I call my ISP and convince them that this a bug)

    Like
      • David S
      • David_S
      • 3 mths ago
      • 1
      • Reported - view

      kmanamcheri I'm with you! I'm sure we're locked out as the modem is what's used to control our speeds from what I've heard. It certainly couldn't hurt to call them and plead your case. Perhaps eero will step in and speak with them if it affects more of their customers with the same scenario. 

      Like 1
  • Down to almost every detail , I am having the exact same problems and I've tried the same actions to correct it. One difference is that I'm using three standard eero devices (not the pro or beacon). The coverage and speeds are great, but certain pages struggle to load, including linkedin.  I've also had sporadic issues with chromecast, some videos on youtube, and loading netflix.  Whenever I switch off of my eero network or plug directly into the modem, everything works just fine.  I also can't log  It's very, very frustrating! I'm for sure it's a problem with my eeros.  I called eero support, and they told me to email them back every time that I had a problem, which is nearly all of the time, so I've sent about 5-10 emails in the last 24 hours about my inability to perform certain actions on the network.  I'll wait until Monday to hear back from the support team, but It's looking like I'm going to have to go with another type of wireless network. As a note, I have a TP-Link TC-7610 modem. kmanamcheri  did you ever get this solved?

    Like 1
    • gormantt I recommend getting the Netgear CM600 and see if that resolves the problem. If not, you can always return it. Not sure where you live, but Best Buy is still doing pickups in store.

      Like
      • gormantt
      • gormantt
      • 2 mths ago
      • Reported - view

      kmanamcheri Thanks for the recommendation! I'll give it  a shot.

      Like
      • David S
      • David_S
      • 2 mths ago
      • Reported - view

      gormantt . I agree the CM 600 is a great modem (I have two CM 600s as backups due to frequent storms where I live - modems don't last long around here), however, make sure the CM 600 is on your ISP's approved list for customer owned modems and rated by them (not just Netgear) for your speed plan before you buy one.

      Like
  • I have the same exact issue, except I have a Zoom 5345 cable modem. I've had the Eero for almost two weeks. Everything works great on a 2018 Macbook Pro. Works fine on a Dell XPS desktop connected via wired Ethernet. If the same Dell XPS, a Microsoft Surface Pro, or an older (2013) Macbook Pro connect via wifi, then general web browsing works but downloading files fails with the connection being reset. 

    Switching back to my old wireless router, everything works fine. 

    I tried connecting my Eero to my cable modem with my old router in between but that still fails. 

    It's unfortunate, seems I'm going to need to return the Eero. I did talk to support but they didn't have anything helpful to add. It's a very strange problem. 

    Like
Like Follow
  • Status Answered
  • 1 mth agoLast active
  • 11Replies
  • 120Views
  • 5 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com