Unable to connect to Synology NAS on Wi-Fi despite being able to ping?

Wondering if anyone can help, as this problem is driving me a bit mad and I can't seem to find the issue. I have also posted this in the Eero subreddit, but despite the very helpful advice from a redditor, I'm still at a loss.

TL/DR: I am unable to connect to my Synology NAS (DS920+ running DSM 7.1.1-42962 Update 4) via my MacBook Pro when the laptop is on wifi, but it's fine when wired via ethernet. Here is my set up in ascending connections:

ZTE 5G Modem in Bridge Mode>Eero Router>Netgear 4 port switcher>Synology NAS

The NAS is connect via ethernet and DHCP with an address of

The laptop is connected via Wifi and DHCP with an address of

I can see the MAC addresses on both the Eero app and relative devices.

I have ports 5000/5001 opened on the NAS via UPnP which are showing as OK when tested.

When I connect my laptop to the switcher, I can connect to the NAS perfectly fine. I can also connect to the NAS via Quickconnect. When I try and load in a browser (have tried both Safari and Chrome), something starts to load, but nothing appears.

I can also ping the IP from Terminal and get a response.

I did think there might an issue between the switcher and the Eero, although I have just replaced the switcher to check if the old switcher caused an issue, but this has not solved things.

I have also hard reset the Eero network (the main puck and two others) but this did not help.

My question is - is there something on the NAS or Eeros' settings which I have missed that would cause a block between wifi and ethernet based devices?

I realise this might not be a specific Synology issue, but having gone through everything with Synology, they suggested the cause might lie with Eero. This only started happening a few weeks ago, so maybe an update shifted something along the way?

Thanks in advance!

8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Do you have the guest network enabled on your eero network? And if so, are you sure your laptop isn’t connecting to that by chance?

  • The guest network is turned off, so it's not that.

    • woobl that’s really odd then. I have a Synology NAS as well and I’ve never encountered this issue (and I only connect to it via Wi-Fi with my MacBook Pro). And you’re also sure that Wi-Fi is turned off on your ZTE router?

  • yes, very odd! The wifi is off on the ZTE Modem - it's just in Bridge Mode. It is serving IP via DHCP, but with a designation of 192.168.0.X, so I don't see how this would affect anything that the Eero is doing. 

  • One thing - I had some issues with OpenVPN a few months ago with regards to certificates. I've disabled OpenVPN since then, but wonder if that might have something to do with things. 

  • If you are unable to connect to your Synology NAS on Wi-Fi despite being able to ping, it may be due to a network configuration issue. Check if the NAS is on the same network segment as your device and if the firewall settings allow access to the NAS. Also, try accessing the NAS using its IP address instead of the hostname.

Like Follow
  • 2 mths agoLast active
  • 8Replies
  • 31Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support