Eero Blocking Wells Fargo

Does anybody else have a similar issue where the Eero network will eventually block certain trustworthy websites?  We are experiencing this issue with two bank websites, one of which is Well Fargo! We tested many different connections and determined it is the Eero that is blocking a user verification process on the bank’s website. We purchased the eero - AC Dual-Band Mesh Wi-Fi System only two months ago and this problem developed after about a month. We called customer support, who were very helpful in helping us troubleshoot but ultimately couldn’t help with this issue. We thought it might be the aero plus subscription which we terminated an order to test the bank logins without it but it still didn’t help.  It appears from this forum but there’s no way to whitelist a website. Also it could be the third-party verification company that Wells Fargo uses that has been blocked and not Wells Fargo itself but that is only a guess. The other bank that has been blocked is a smaller bank, FNBO, we are guessing probably uses the same technology as Wells Fargo. We are shopping for other mesh networks since there doesn’t seem to be a solution to this problem for the eero and we are just crossing our fingers that the competitor’s software doesn’t also block trustworthy sites. We are really sad to have to abandon the eero system because we’ve had really great connectivity and speed with this mesh network.

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi there, Lazam . Thanks for reaching out. This definitely sounds like an odd situation, especially if disabling eero Secure's blocking and security features did not resolve the issue. I understand that you've contacted support already, but I'd like to be able to escalate this to be looked into further.

    Whenever you're able to, please email us at support@eero.com with the subject "Community Followup" so we can take a look.

    We look forward to hearing back from you!


    Kora | eero Community Team

  • This just started again after Wells Fargo updated their online banking site on March 26, 2021.  I am unable to connect to Wells Fargo online banking from any computer on my Eero Pro 6 network, either over WiFi or connected directly to the Eero device that does the routing.  I am able to connect to the Wells Fargo site using the same browser (Chrome) on my phone, though.  I have turned off Eero security and turned off DNS caching and restarted the network, but this does not help. I have tried both Firefox and Chrome and I have tried both my desktop and my laptop.  I have cleared my browser cache.  None of these things help.  I have whitelisted the Wells Fargo site in my browser and in my ad blocking and anti-malware software.  I have tried connecting over a VPN.  None of these things help.

Like Follow
  • 2 wk agoLast active
  • 2Replies
  • 29Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support