New eero Pro 6E on Bell Fibe - No Internet

I am setting up a new eero Pro 6E on BellAliant Fibe in Canada and am not having much success.

First, I tried connecting to my Fibe modem via double-NAT and doing this, the router is able to connect to the internet.  If I read this article correctly, this is something that should work.

However, I connected both an iPad and an iPhone to the eero via Wifi and although they get a valid IP and can be seen as connected on the eero app, neither were able to access the internet.

After some research on the community forum, I found the following:

jhollington said:
The potential third option is to look for a feature called "Advanced DMZ" or some such. Again, I'm not a CenturyLink customer, but I've read several reports that this is a possibility on at least some of their routers, and it's what I'm using with my ISP (Bell Fibe in Canada). The "Advanced DMZ" feature lets the router actually assign the *public* IP address to the Eero, at which point it acts just like the C1000A isn't in the loop at all.

So I setup Advanced DMZ on my modem for the eero.  The modem shows the eero as being properly connected and having been assigned a public IP address.  However, after doing this and rebooting the eero, it’s light is red as is unable to connect to the internet.

From what I can see in the modem settings, and because I use it to also use it for phone and TV services, I do not believe that I can set it to Bridge mode.  (There is no options for this in its settings either unfortunately.)

Is there anything else that I could try to get the device working?  Has anyone else had a similar issue, and if so, were you able to resolve this?

Thanks in advance!

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I spent many hours trying to debug this yesterday and again today with no success.   Today I tried setting up PPPoE to login with the eero through the Advanced DMZ and VLAN 35, but still no connection.  Also, I seem to be unable to connect to the admin interface when the internet is not working, even when I connect via Wifi.  Is that normal?  I’ve not experienced that before…

  • Did some more testing and found that if I changed from “Manual DHCP & NAT” to “Automatic DHCP & NAT”, it seems to work perfectly with double-NAT on my Bell Fibe router.

    Is there someone from eero support (maybe Evan (eero support) ?) that I could tag to help determine if this (Manual DHCP…) not working is a bug? 

    • Sébastien Depending on the IP range of the upstream router and what IP range you were trying to set for the Manual DHCP setting, it may be expected due to overlap of the ranges. I would suggest calling or emailing us so we can properly look into this.

    • Evan (eero support) , Thanks the update - It is very likely the source of the issue: I had a subnet mask of under subnet IP  My modem is using which falls within that mask.  I tried manual again, but this time with a range of and an it seems to work perfectly.

      I had called support twice already.  The first time they indicated there was an issue with the provider modem (there likely was).  The second time they told me that double-nat would not work and that I needed to setup my provider modem to bridge mode, which is odd since it does support double-nat.  I tried to work with them to find other potential causes, but unfortunately, the agent I talked to was not opened to that.  It would have been much easier if they had mentioned this at that time!  (I didn’t know what further questions to ask at the time - still learning how eero works…)

      I really appreciate your input!  If not for your solution, I likely would have returned the 6 eero’s that I had just purchased and looked for an alternate solution.

  • Power cycle your eeros: Try power cycling your eeros by unplugging the power cable from the back of your eero, waiting 30 seconds, and plugging it back in. This step can sometimes fix connectivity issues. The eero's LED will turn solid white, then be flashing white while booting up.



Like Follow
  • 7 mths agoLast active
  • 5Replies
  • 224Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support