EERO 6E Pro - Change Gateway IP Address


ISP: Rogers - comes into basement utility room and is connected to managed switch that feeds a wired home

- I do not want to put an eero in the utility room as it will be very expensive without adding coverage

- I have two EERO Routers and want them on the main floor and 2nd floor of our home to provide wifi coverage to wireless devices (including access to the printer and NAS devices on the wired network)

Base network is 192.168.2.X

- Originally ran the EERO in bridge mode - which worked fine but restricted certain features

- Release of EERO built in to extend the mesh to our Echo's and Echo Dot's made me want to use that feature


- So i venture off to meet a few requirements:

1) Enable EERO Built-In

2) Run the EERO network on the same network as our wired network 192.168.2.X

3) Ensure all devices have access to the printer and NAS devices on the 192.168.2.X network

4) continue to use the ISP router which uses and cannot be changed

5) ISP Router DHCP has a range of

6) EERO DHCP Range will be set to


ISSUES: When I set the EERO to use the subnet 192.168.2.X - it automatically assigns itself the IP ADDRESS which is a conflict with the ISP Router

 - I need to be able to set that LAN IP address - or what they call the Gateway EERO IP Address

I set this as follows to ensure no conflicts with the existing network

  1. Open Eero -> Settings -> Network settings -> DHCP & NAT
  2. Change the DHCP & NAT from Automatic to Manual IP
  3. Leave IP Prefix unchanged as
  4. Edit Subnet IP to be:
  5. Edit subnet mask to be:
  6. Edit Starting IP to 
  7. Edit Ending IP to

Note the Static IP settings are only for the WAN IP Address.  I want to set my LAN IP Address to to ensure no conflict with the ISP Router.

I realize that I could add a third EERO to my utility room - bridge my ISP router into the EERO but that is a very expensive solution.

All I need to do is figure out how to change my EERO's LAN IP (Gateway EERO IP) 

I have been working with support and we have not been able to find a way to do this yet.  Any ideas?

6 replies

    • Michael_eero_support
    • 1 yr ago
    • Reported - view

    Hi rennera

    Unfortunately it is not possible to do what you are intending to do.  The subnet an eero uses has to start with x.x.x.0 and the gateway eero will take x.x.x.1 for DHCP calls, there is no way to change this.

    Even if it was possible you would be running two DHCP servers on the same subnet, both responding to calls on the network.  Things would get very messy and unstable quickly, not something you want to do.

    Our only solution to using the eero unbridged (so you can use your Echos) and keep the 192.168.2.x network would be to bridge your current router and put another eero in its place to be the router (so go ISP Rogers->Gateway eero->switch->other hardwired devices and eero, you will want to disable all the management features on that current switch in this scenario).

    The other solution would be to use the eero for only wireless devices with your current topology, but the wireless devices would be on a different subnet and would not be able to talk to things on the hardwired subnet, again, won't do what you are wanting to do.

    • rennera
    • 1 yr ago
    • Reported - view

    Routers responding to calls on the same subnet is not an issue - this is why we have a DHCP range.  

    As Described above... 

    ISP Router DHCP has a range of

    EERO DHCP Range will be set to

    Allowing us to set the LAN IP on the EERO would make this so simple or hey how about the EERO using an IP Address within the DHCP range.  

    This is really unacceptable for a PRO product in this price range. 

    I was really hoping to simplify/expand my network with EERO but it appears with your response that the only way to do that is to spend another $400 on an additional router so I can bridge my network in the utility room.  

    I guess I will have to return them all and get some ARUBA access points.

    • rennera
    • 1 yr ago
    • Reported - view

    I guess the other possibility is enabling EERO Built-In on bridged connections - not sure why that feature doesn't work in that setup.

    It's a shame as the product was working reasonably well.

    • rennera
    • 1 yr ago
    • Reported - view

    FYI to anyone following this thread - I caved and bridged my ISP modem and added a third router.  Luckily, Amazon had a deal on the 3 pack and I was able to return the other 2.  I am not thrilled that I am losing the firewall capabilities from the ISP router but the wifi solution is working well.  Hopefully, Eero will enable some firewall options in this premium product without requiring a subscription.  

    • rennera
    • 1 yr ago
    • Reported - view

    I really don't like the fact that I do not have a firewall while using the EERO as the main router.  I am going to try another solution.  I am going to move my ISP router to another subnet like and then leave my EERO on my existing subnet and have it Double Nat'ed.  My thinking is that this will serve a few purposes 

    • existing static IP's on the network will not need to be changed
    • Printers, NAS devices, cameras and other peripheral devices will all see each other on the network
    • Network will be protected by the ISP routers firewall
    • ISP router will still be accessible from its WIFI or by plugging into the router
    • EERO built in will still be enabled
    • All eero features will be accessible (not like in bridge mode) 

    I will post an update after I complete this change

    • rennera
    • 1 yr ago
    • Reported - view

    UPDATE: EERO is now working behind the firewalled ISP router.  

    This makes me feel a lot better about the setup.

    • Connected laptop to second port on ISP router
    • Connected to router via previously configured LAN address (if not configured in past use
    • Disconnected cable from EERO so that I could reconfigure LAN and DHCP on ISP Router
    • Disabled Bridge Mode on ISP Router
    • Changed LAN IP Address and DHCP Scope to 192.168.3.x -- this step is the key to eliminate conflicts on your network - you want EERO to use the subnet that your router was previously using
    • Reconnected to ISP router via
    • Reconnect EERO which will get a DHCP address from the ISP router 
    • Disconnect cable from laptop and ISP router
    • now all devices are connected via EERO on 192.168.2.x subnet
      • printers, NAS, Cameras etc all still work without any change
      • in order to connect to the ISP router I can still access it via even though my devices are on the 192.168.2.x subnet

    You can see in the images - my firewall is protecting the entire network now 🙂.  The only device showing connected is EERO.

Content aside

  • 1 yr agoLast active
  • 6Replies
  • 2586Views
  • 4 Following