0

eero pro won't talk to moca

My modem is in a closet next to the Comcast box in another part of the building (this is necessary - I can't move the modem). The POE coax runs into my modem, which connects to a Hitron moca 2.5 adapter in the closet and then runs through the building by coax into my apartment where it feeds into another Hitron moca 2.5 adapter, see diagram. When I connect the moca adapter to the gateway eero it (the eero) just flashes white for a couple minutes and then turns red; however, if I run the moca adapter into my old linksys router and then into the gateway eero it works perfectly.

In other words POE > Modem > Moca > Moca > eero = fail, but POE > Modem > Moca > Moca > linksys router > eero = success. The eero also works perfectly when connected directly to the modem. This tells me there is nothing wrong with the connection, the cable,  the modem, the eero gateway, or the adapters and that something is very wrong with the eero/moca interface. This is baffling for 2 reasons: 1) moca is just a transparent networking system that should work identical to a network cable (eero shouldn't even know its there), and 2) Ive read online that people have plugged eeros directly into a moca adapter and they just work. 

The bridge router workaround is both inefficient and inconsistent with how the gateway is supposed to work. I tried unsuccessfully to solve the problem by switching to Motorola moca adapters and a handful of other workarounds to no avail. Is the problem simply that eero pro cannot interface directly with moca? I am hoping there is a simple setup or software update solution that will resolve this issue.

So desperate at this point, PLEASE HELP!!!!  

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello KDH ,

    Thank you for all the testing that you have done and the great topology map. As far as I am aware eeros work with all MOCA devices because, as you stated, they are just a transparent way to push an internet connection through your home. Out of curiosity, have you tried the other eeros in the Gateway position? Also, have you tried performing a soft reset on the Gateway eero?

    If neither of those tests work, please give our support phone lines a call with this information so we can take a look at the network to identify what might be happening here. I will share a link below so you can find the best number to contact us at.

    https://support.eero.com/hc/en-us/articles/215473703-How-do-I-reset-my-eero-

    https://support.eero.com/hc/en-us/articles/207376426-How-do-I-contact-eero-support-

    Like
  • The only thing I can think of that I haven't tried is deleting the network. This is the nuclear option I wanted to avoid as I will have to spend days reconfiguring all the smart devices, lights, etc that connect through the existing network. I'm pretty sure I would have to delete the entire network to change the gateway from one eero to another, no? If that's the case, hoping to avoid it at all costs. 

    That said, I created a moca mini-loop to test one of the non-gateway eero's. In the pic (pardon the mess) I took the network line from the wall, ran it into a moca connected to a second moca by coax cable and finally ran the network cable into the eero. Thats works; however, the loop is inside the linksys router so it would seem that eero can talk to a moca adapter, but still needs an additional router. I don' t understand why the eero could take data directly from a modem but not from modem if theres moca in between. 

    Is there anyone on your team that has experience with moca adapter > eero pro setup? I seek moca Yoda

     

    Like
    • Hello KDH ,

      I've worked with customers with MOCA setups before. eeros absolutely work with MOCA. You do not need to hard reset your network to swap the Gateway. Though you may need to power-cycle your modem though. But all you should have to do is just unplug your current Gateway and plug in the second eero we're testing with in order to swap the Gateway out. Also you've been swapping the eero and your other router so you would know if you needed to power-cycle the modem or not at this point.

      If you try this and it is still not working, please give our support lines a call so we can dig a little, get device model numbers, and work to identify what might be causing this behavior.

      Like
  • I tried the switch, no dice. I never got it to work; however, I solved the problem by replacing my modem w/a combination modem router. I shut off the wireless functionality of the new router to reduce noise and any pressure on bandwidth. This worked as the data has already been 'routed' once it reaches the eero gateway through the moca adapters. This was a very expensive solution but did solve the problem. I would appreciate if eero will research why an eero gateway can't receive unrouted data from a modem over moca. Thanks! 

    Like
    • Hello KDH  ,

      We can take a look. Can you gather the make/model of the old modem, the MOCA system, and the network topology you created above and send it in an email to support@eero.com? You may want to consider giving our support a call as well to make sure we're getting all the information we need as quickly as possible.

      Like
Like Follow
  • 2 wk agoLast active
  • 5Replies
  • 13Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com