HP LaserJet Pro disconnects from eero (wireless)


Since I have changed my network to eero, my HP printer always disconnects from the network and needs to be restarted to reconnect (i.e. power off and power on the printer).

With my prior setup with FritzBox the printer was always connected.

I believe the printer looses wireless connection when going into standby, and does not reconnect after wake-up.

Any ideas?

16replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I have the exact same issue and I must say I am disappointed that there has been no response to your original question for the past month.  This printer operated on my old Linksys WiFi network without issue for nearly 10 years.  Problems started immediately once up on eero.

    In searching on HP's support site I found what I *hoped* was my solution: a firmware upgrade that specifically identified this issue:

    • "Fixes an issue that could cause loss of network connectivity on wireless networks with multiple access points having the same SSID."

    Unfortunately, after successfully upgrading the firmware, the next morning the printer was again "offline".  I find it interesting that the printer's network status / configuration status when it is in this offline condition is "Waiting for a wireless connection".

    Judging by how many people are running into identical "wireless looses connection..." type printer issues (not just HP printers) this is clearly something that needs a solution.


    Like 3
      • Tarek
      • Tarek
      • 1 yr ago
      • 1
      • Reported - view

      jcyoungiii Thanks for sharing. 
      I wouldn’t care to much if AirPrint would work while using both, Ethernet and wireless, in parallel. But unfortunately, it requires wireless only. 
      I will keep the post alive, maybe someone stumbles on a solution...

      Like 1
    • jcyoungiii 


      Same issue here with HP LaserJet 300 colorMFP M375nw with firmware date code: 20150126

      The printer joins WiFi on a HARD power reboot, last for about an 6 hours, then dies.   We are also putting a continuous ping to the device and it does not seem to help.  Now mapping WiFi access with Cacti to confirm exact time out.

      Communication Mode: Infrastructure
      Authentication Type: wpa2-psk
      Encryption: aes


      Band steering and WPA3 are disabled on EERO.

      This printer worked on a Cisco 3702i running "flash:/ap3g2-k9w7-mx.153-3.JPJ3/ap3g2-k9w7-xx.153-3.JPJ3" for over a decade.  You just can't beat commercial products I guess.

      Like 1
  • Same problem here, with a HP LaserJet Pro M255DW. The disconnection started when we added the second Eero device to our network.

    Like 2
  • Same issue here with my Brother MFC-L8850CDW so not just an issue with HPs it seems. There should be some way to tell eero which devices we want to always be connected.

    Like 1
  • Same here, also a Brother J460DW. Could it be solved on the printer side by forcing it not to sleep?

  • Hi, I solved the issue by upgrading the printer firmware. 

      • doshia2
      • doshia2
      • 6 mths ago
      • Reported - view

      Gualtiero So when u upgraded the software, did printer respond to your phone and Ipad?

      My printer 8720, does recognize my HP laptop(2019), but not Iphone N ipad??

  • Glad that worked for you - it did nothing for my problem.  Got tired of waiting for a solution (or even a response from Eero) and just put the printer on the LAN.  Problem "solved" with workaround.



  • Hi

    My son bought an EERO for us and installed it last week. A few days ago, we tried to print...the printer only responds to one device...our 2020HP laptop/15. Our Iphone and Ipads will not connect. Should we return the EERO 3 pods as they do not work for us? Or is there a simple answer everyone on the thread is missing??

  • Hi, I also have this problem after moving to a 3 Eero system last week. My HP Envy 4500 printer continually loses wireless connection and only a restart will fix it temporarily. I have given the printer a Fixed IP as that was a suggested resolution but no change. Printer firmware reports as up to date. It has been totally reliable over the past few years but doesn’t like the Eero network it seems. Surely this can’t be beyond HP/Eero to resolve!


  • Anything new on this topic?

    I'm having the same problem.   Started about a year ago, i don't recall it occurring when I initially installed EERO.  It definitely wasn't occurring with my Comcast WIFI setup.  

     First it was with my HP OfficeJet Pro 8620 - the printer was several years old so i thought it just wasn't able to handle the EERO Pro 3 node setup - no firmware updates avaiable.    So I just purchased a new HP OfficeJet Pro 9015e this week and have the SAME problem.   

    Any help would be very much appreciated.   I'm getting ready to move to another WIFI setup.

    Like 1
  • Same issue.  Called eero support.  877 659 2347.  1 minute hold.  Fixed problem in 2 minutes.  I had enabled WPA3 enhanced encryption in settings which my 3 year old HP printer apparently couldn't handle.  They remoted in and changed that setting and it works.  Support was awesome.  Thank you

      • Tony
      • Tony.2
      • 2 wk ago
      • Reported - view

      Q007 Any idea how we can disable the WPA3 enhanced encryption or does EERO support need to do this?  Thanks for any help you can provide.

      • Q007
      • Q007
      • 2 wk ago
      • Reported - view

      Tony In eero app go to discover tab.   Go to eero labs.  Toggle off WPA3.  Feature doesn’t work with older hardware.

  • I've already hard-wired my printer to get around this, but no way should I have to have an Eero tech remote into my home network to get an HP printer WiFi connection to work.

    Just sayin...


Like3 Follow
  • 2 wk agoLast active
  • 16Replies
  • 360Views
  • 14 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support