0

IPv6 shows as IP address

Last night my iPhone 11 showed a week signal. When I checked in the Eero app the IP address showed a long string of characters that looked like a MAC address. I’m assuming it was an IPv6 address. I don’t have IPv6 enabled so why would this show up? All my other devices show 192.168.4. ***********. I installed the latest 6.3 software update the night before. Is someone else connecting to my I phone? Worried about a security issue. Thanks.

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello Jackietools ,

    Were you able to take a screen shot of what you are seeing? Were you in the eero app? If so, what screen were you on? It would be exceptionally difficult for someone to gain access to your iPhone through your eero and someone hacking through your eero into your phone is highly unlikely. However, I would still like to identify what you saw to put your worries to rest.

    Like
  • Yes I was in eero app, home screen and under list of devices i opened my iphone and the ip address looked like a Ipv6 address.When i go to it now it is showin IP4 address but if I expand IP address it shows one IP4 address and 2 IP6 addresses 

    Like
  • Last night it showed as IPv6 address

    Like
    • Jackietools 

      That is fine. Even if IPv6 is not enabled your devices will be assigned an IPv6 address internally which is what those address you're seeing there are. The reason you have two could be due to Apple's Private address feature which changes your mac id every time you connect to a network. You can turn this off for your home network in the WiFi settings of your iPhone and in the specific network information for your home network. Just click the little "i" to the right of your home network and it will turn off this feature for just your home network. But you are safe and what you are seeing there is normal.

      If you happen to see the IPv6 address in the IPv4 section again please screen shot it and share so we can try and identify if it is a bug with the app.

      Like
  • Thanks for your help. If I see it again I’ll try to send a screenshot 

    Like
  • Should I enable IPv6? Do I first have to enable it in my Verizon router? What if any problems can it cause? Thanks

    Like
Like Follow
  • 4 mths agoLast active
  • 6Replies
  • 66Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com