Devices on different subnet, can't communicate (Roku)

Basic issue: my iphone Roku app cannot see my Roku device for remote control. Roku support states the IP Address must have the same first 3 digits. Alas, mine do not. What controls this, and how can it be fixed?

I have 2 eero Pro 6 devices - Office and LivingRoom. I have no other router - my external internet comes right into my eero, via a small Frontier device that converts coax to ethernet which is plugged into Office eero.

My iPhone has an IP Address of It may roam between the two eero devices.

My Roku connected to my LivingRoom, as expected. It reported IP, with Gateway

The issue is the third digit - iPhone is ".4." while Roku is ".5.". I unplugged my Roku, but it rebooted with the same IP.

How can I get the IP address to be the same first 3 numbers?

5 replies

    • MattMN
    • 6 mths ago
    • Reported - view

    I have verified they are on the same wireless network. I only have 1 wireless network. Neither device is connect to 'a neighbors' wifi - I have explicitly selected my network and entered my password.

      • Michael_eero_support
      • 6 mths ago
      • Reported - view

      MattMN This is actually normal with an eero's default settings.

      By default eero uses a larger than normal subnet than most consumer routers.

      Most consumer routers, historically, have used a single digit subnet, like 192.168.7.x, 192.168.1.x or 10.0.1.x

      Anything that didn't match the first three sets were not able to talk to anything outside, so something on 192.168.1.x cannot talk to something on 192.168.7.x, but could talk to

      eero uses a larger subnet, it uses 192.168.4.x-192.168.7.x by default, so anything on that range can talk to each other.

      It sounds like one of your devices doesn't play well with that larger subnet.  I would suggest changing eero's settings so it uses the more limited subnet range.

      Here is how:

      Go to eero app->Settings->Network Settings->DHCP & NAT, move the dot to Manual IP

      Select the premade option and scroll down.  Put in the following values:

      Subnet IP:

      Subnet mask:

      Starting IP:

      Ending IP and click save, the network will reboot.

      This will be suitable for a network of up to 240ish devices.  See if that helps.

      • MattMN
      • 5 mths ago
      • Reported - view

      Michael_eero_support FYI for other users, this did the trick for me. Great success, thanks for the tip.

    • MattMN
    • 6 mths ago
    • Reported - view

    Awesome, I will try that, thanks. 240 devices should be fine! 🙂

    Will all my devices that currently have an IP outside that range, automatically get the new IP? Any anticipated issues, or device restarting required?

      • Michael_eero_support
      • 6 mths ago
      • Reported - view

      MattMN they should get a new IP address in the range when they reconnect (from the device's perspective the wifi will vanish while it reboots and then comes back on).  If something doesn't work after the network reboots and it reconnects, just reboot the device, that should do the trick.

Content aside

  • Status Answered
  • 5 mths agoLast active
  • 5Replies
  • 241Views
  • 3 Following