Accessing Public IP from LAN side and DDNS

This might be a long one but want to be clear and thorough.  My previous setup before I got the eeros was my ATT PACE 5268AC fiber gateway --> Asus AC68 (setup in DMZplus mode on the ATT PACE so it takes the WAN IP) --> 16port switch for other wired devices like other eeros, and other hardwired devices.  This allowed me to connect to WAN IP or the DDNS name even from the LAN side (like my iPhone on the wifi network, it could easily hit the DDNS name of my Network Video camera unit).

 

Now my setup is ATT PACE 5268 fiber gateway --> Primary eero --> 16port switch for other wired devices like other eeros, and other hardwired devices.

 

On my previous Asus AC68 router/gateway/wifi device we had the capability of adding a DDNS or Asus provided one, like mine was xxxx.asuscomm.com . So allows me to access my home server or network cameras without having to remember my WAN IP. Does eero not have a feature for this or is it in the plans for future release? If so when?

Secondly, being that I have network cameras and other smart devices like electricity monitoring apps on my smartphone, I had the smartphone apps look at that DDNS name like my Qsee Network cameras would point to xxxx.asuscomm.com to access the cameras. That worked remotely while I was on say a cellular LTE network or even inside the house. Right now that concept (here I use the public IP on the app) doesn't work inside the LAN network. Only works when Im on Cellular LTE (meaning the port forwarding and all that is correct). Seems eero from inside its LAN network doesn't know how to reroute itself via say my public IP or DDNS name to the server/device inside my network. Again Asus, Linksys, even Belkin routers had this capability. Ive been using this for 5-8yrs now.

Now I have no choice but to constantly change that address on the smartphone app if Im inside my house and when Im remote I need to use the public IP.

 

Or my only options is to put the Asus AC68 back in as the main router and let the eero sit in Bridge mode, but was trying to eliminate these devices and clean this up.

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Just to close this out, seems like there is no way for eero to support this right now, so its basically going to be a feature request.  For now Im having to put my Asus AC68 back in as the main router/nat/dhcp/ unit behind the ATT Fiber gateway, and let the eero's hang off my Asus/Switch in Bridge mode only.

     

    Dixit

    Reply Like
  • I have a similar issue as I run a macOS server for calendars. I was able to access these from the WAN and LAN with Apple Extreme router. The only way I've gotten it to work with eero is to set up DNS on the server and use the server IP address as the primary DNS address on a custom DNS setting on the eero. I'll add my two cents that it would be a nice feature to have in a future release. We are certainly fringe cases with our setups.

    Reply Like
  • Setting up a DNS would've worked, but it would have to route to local LAN IP since even from LAN it couldn't transverse using WAN IP directly.  But your solution works as well, I decided to just put the Asus AC68 router back as it has more flexibility for me as the main router/dhcp/port forwarding unit than the eero currently has.  

    Reply Like
  • Being on the cutting edge has it's drawbacks. Glad you have a solution that works for you!

    Reply Like
  • similar to this feature request - might merge these threads

    https://community.eero.com/t/q561rb/egress-hairpinning

     

    Reply Like
  • Been asking for this for about a year

    Reply Like
  • Hi everyone —

    With eeroOS 3.3, we released support for Hairpin NAT. Please see the following for more information:

    https://community.eero.com/r/y7fg8g

    Reply Like
login to reply
Like3 Follow
  • Status Implemented
  • 3 Liked by
  • 2 mths agoLast active
  • 7Replies
  • 1107Views
  • 7 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com


Latest from the eero blog

eero, plus peace of mind

Learn more about eero Plus and how our security suite helps to keep both your devices and everyone in your home safe while online.