Ring Doorbell

I have a ring video doorbell that I am trying to connect to my eero 2nd generation home wife system. I'm using an IPhone. From my understanding the ring doorbell work on 2.4 GHz only, and, my IPhone is using 5 MHz. I've had two suggestions, 1) restart the IPhone when you connect the doorbell (apparently it goes to 2.4 GHz first) or 2) go as far as you can from the network and IPhone will switch to 2.4 GHz since it connects the furthest. Neither of these suggestions worked, any other suggestions?

11replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi  chrisjgallant

    Sorry to hear the issue you're experiencing with connecting your Ring Doorbell.

    By any chance, was this device on a previous WiFi network? If so, please try resetting the network settings of your Ring doorbell. From what I can find, you will likely need to factory reset your Ring doorbell to take this action by holding down the orange button for at least 30 seconds.

    If this is a new doorbell, or you continue to have issues after trying the factory reset, please contact eero support by giving us a call at 877-659-2347 or emailing support@eero.com .

    Reply Like 1
  • Hi thanks Jeff, I've tried everything, even rebooting, the system goes through its paces and when it comes time to do the connect, it stops. I've done the 30 plus second hold on the orange button, and rebooting the modem, eero and so on...to no avail. I've spoken to tech support at Eero and they are the ones that made the two suggestions above.

    Reply Like
  • chrisjgallant

    Thanks for trying those things and I’m sorry to hear they weren’t able to resolve this matter for you.

    While it isn’t a perfect solution, we’d recommend to continue to try and move your iPhone out of range of 5 Ghz. From the eero app, you can monitor the connection by opening the app and tapping into the connected devices. Once you tap on your iPhone, you’ll be able to see when it switches from 5 Ghz to 2.4 Ghz.

    Please let us know if that continues to not work, and we can hopefully find another solution.

    Reply Like
  • I tried walking away, but then one of my beacons went offline, then my wifi was gone, it never went down to 2.4 it basically showed 5 then nothing. I now deleted the eero app and will get a fresh one from app store and start from scratch.

    Reply Like
  • Jeff here is a thought, what if I connected my Linksys wireless router to the eero, thereby allowing me to use it for 2.4ghz products, would that work?

    Reply Like
    • chrisjgallant - in addition to what Jeff is saying, there isn’t technically an issue with having some devices on 2.4 and some on 5 GHz. I have a mix of both on my network (my Nest cameras and Logitech Harmony hub are just some examples), and I have no issue connection/controlling those all on my eero network. It kinda sounds like something is wonky with the Ring doorbell and/or it didn’t properly get reset to factory defaults.

      Reply Like
  • chrisjgallant  —

    That won't work as it isn't possible to have a third-party router mesh with or extend an eero network.

    We should definitely have our team take a look at what is happening. However, if you'd like to try one last thing, it shouldn't ever be necessary, but it may work.

    If you still have your old Linksys router, disconnect your main eero from the modem and reconnect the Linksys. Set the network name and password for the 2.4 Ghz network to the same as your eero network. Set up the 2.4 Ghz devices and then remove the Linksys router and plug back in your eeros.

    From there, these devices should have no issue connecting and staying on your eero network.

    Thanks again for your ongoing patience as we've worked through this issue. 

    Reply Like
  • Thanks Jeff sounds like a good idea, will try tomorrow morning first thing.

    Reply Like
  • Good morning Jeff, it worked. I reconnected the Linksys router, gave it the same name, blocked the 5GHz, connected all of the outlets and bang, once the eero was back online, so were they. The doorbell however did not connect either way, I believe there is something wrong with it. Anyways, good plan thanks for your help.

    Reply Like 1
  • Ring Pro Camera (hard wired) issues with EERO Pro! - SOLVED

    I was so mad that I was getting ready to send back the Ring Pro cameras!  I was getting so frustrated!!  I used EERO Pro for months and loved it, but could NOT hook up my new Ring Pro (hardwired...did not want to change batteries) system!

    When the Ring Pro camera sees the EERO Pro mesh network (usually at full/Excellent strength), it asks for the Wi-Fi password and unfortunately after you ENTER IT PROPERLY, it does not connect.  The Ring Pro camera "thinks" you have entered the wrong password, via the app, when...THAT IS NOT THE CASE.  Then the Ring camera goes from a flashing blue light to a flashing red light...BAD! 

    To verify the Ring Pro camera was working properly, I temporarily hooked the camera to my iPad hot spot and it worked perfectly!  So, I eliminated that the camera was defective itself.

    What happened is that the EERO Pro mesh WiFi was trying to connect via 5.2 or 5.8 Ghz ONLY!!  The Ring Pro camera only operates at 2.4GHz.  Even though EERO Pro does operate at 2.4 GHz.  It did not switch down to it because it was close to the router.

    The next time I tried to install the Ring Pro camera to my EERO mesh system, I walked my iPhone (with the app opened up and ready to enter the Wi-Fi password) about a good 75-80 feet away from the EERO PRO mesh system to "force" the EERO to switch down to the 2.4 GHz band...again, before entering my Wi-Fi password,...and IT WORKED!

    Again...take your phone, with the Ring app, and walk a good distance AWAY from the EERO Pro mesh system to FORCE IT to connect at 2,4 GHz...BEFORE you enter your password!

    Now it works! 

    Reply Like
    • ed How did you go about checking the state of your connection while also waiting to enter the password?  I was attempting to mimic your approach when getting my Chime doorbell to connect (it suffers the same issue where it grabs the 5ghz band on my Eero), but whenever I connect to the Chime's wireless to do the setup I lose my Eero connection.  Maybe the Ring Pro behaves differently?

      Reply Like
Like Follow
  • 2 wk agoLast active
  • 11Replies
  • 5827Views
  • 5 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support