Problem in switching eero to AP mode (bridge mode)

I've done this before successfully, but spent hours last night trying to switch my eero from routing to AP mode. This is so I can use my router as traffic meter to monitor my Comcast data usage, and just use the eero for wireless. 

What I tried last night:

The eero was in router mode, so I brought up the other router (Netgear R7800), and connected the eero to the R7800 without switching to bridge mode yet. I've had good success in moving the eero from standalone router mode to router mode (double NAT) connected to the R7800 LAN port. This should be a slam-dunk. Once I had the R7800 going, I connected the gateway eero (in router mode, remember) to the R7800, and power-cycled the gateway eero. eero light blinked white for a long time, and then went orange. Tried power-cycling the gateway eero several times, only got orange lights.

Okay, so I figured I had to start over with configuring the eero. So I left it connected to the R7800, used the eero app to delete the eero network. Then I unplugged the two remote eeros, and reset the gateway eero. I figured that the gateway eero would be fine with internet from the R7800. Waited until the light was blinking blue (bluetooth pairing mode) and went into the app to configure the eero...since I had deleted the eero network, the app immediately went into "configure a network mode", exactly what I needed. Well, the app did not connect with the gateway eero via bluetooth for some reason, searched several times. Finally went with entering the serial number of the gateway eero, and the app said that it found the eero. The app went through it's usual configuration steps, ending with "Found a problem, try again or contact eero support". Again, tried this several times, same result.

The bottom line was I couldn't even configure the eero as a second router, which usually works...takes some time, but it usually works. I was also disturbed by the fact that the app on my phone couldn't find the gateway eero when it was in bluetooth pairing mode. When the eero wasn't found via bluetooth, I tried turning bluetooth on and off on my phone a few times to see if I could get it to rescan or something. No luck. And when the app was in contact with the gateway eero, it could not configure it to work as it had before.

Any ideas of what I could try to get the eero into AP mode successfully? I have had no success changing the eero to bridge mode and then connecting it to the R7800 when it was up. That never works, I always end up having to go back to router mode on the eero, and starting it up as a second router connected to the R7800. But now that I can't do that, how can I get the eero set up in AP mode at all? I was able to set the eero back up late last night (early this morning) in full router mode, connected directly to the modem, I can usually do that, assuming I've been able to delete the previous eero network.

Part of the problem is that what I can do is very limited because the eero has to be in touch with home base to be configurable, I have no control here at home for configuration, and it has gotten more and more frustrating over time. It may be that the eero isn't for me, since I change my configuration occasionally to fit my current needs, and I need to be able to do that. I really like how the eero works when I can get it to work, but at the moment I need it as an AP since I can't afford to go over the Comcast data cap.


2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I should add that the eero app finding the two remote eero nodes via bluetooth when I went back to full router configuration with the eero worked well. However, the app would not find the gateway node via bluetooth (which seems to work better than using the eero serial number for me), which, again, was disturbing to me.

  • Okay, this one solved itself, rare but reassuring. Tried one more time to switch to AP mode via turning on main router and plugging eero into it with the eero in router mode. In other words, I started over, switched the internet cable from the modem from the eero into my main router, and plugged the eero into my main router. The eero light again blinked white for a long time and eventually turned orange. So I tried power-cycling the eero as usual, and then left it alone, and fiddled with my main router to make sure that it was up and working right. Again, the eero flashed white for some time, and then turned orange. Just left the eero alone showing orange, figuring I'd try something different with the eero in a while.

    Well, to my surprise, after a few minutes the eero light had turned solid white by itself. I wasn't watching it, so I don't know if it went through it's blinking phase or not, but I was really surprised. I didn't know that the eero would try again on it's own, I thought that once the orange light was on that it just sat there stupefied until it was power-cycled or reset. Turns out that the eero must re-try on it's own, since it did do that, and finally connected in router mode.

    So I switched it to AP mode at that point, and everybody's happy for the time being. Glad to see, though, that eero doesn't just give up when it gets confused. It apparently tries to start over on it's own. Good news!

    Now I have the nice LEDE firmware bandwidth monitor available on my main router, and can see how I'm doing with the Comcast data cap on the 3 Roku's we have in the house. Which is a big issue, gets very expensive quickly if I go over the data cap.

    I really wish that the eero did per-ip bandwidth monitoring like the LEDE firmware for the Netgear R7800 does, but it doesn't. The eero does work well as an expensive AP, though *smile*.

Like Follow
  • Status Answered
  • 4 yrs agoLast active
  • 2Replies
  • 774Views
  • 1 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support