1

Problems with Eero Pro 6, Wemo plug and HomeKit

Anyone having this issue with Wemo plugs being able to Not being able to connect to HomeKit ?

I use to have an Eero Pro and I was able to add the plugs via the wemo app and then to Homekit. 
With Eero Pro 6, I'm able to add the plugs via the wemo app but impossible to add them to Homekit. I get an error saying accessory was not found. I have 5 plugs like that. 

Thanks

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I noticed that if I restart my eero pro 6, I can add my wemo plug via the app and the add it to Homekit successfully. For each plug, I have to restart my eero in order to set it up with homekit. 
    can someone at eero take a look at this problem?

    Like
  • Sometimes devices will need to be on an exclusive 2.4ghz network during the initial setup process to work correctly, don’t know if it also need it during HomeKit setup (I run Alexa), but I would assume so since HomeKit is a single-step add devices (instead of Alexa’s 3-4 steps).

     

    To temporarily disable 5ghz network (15min at a time), go to Settings > Troubleshoot > My device won’t connect > my device is 2.4ghz only

     

    the previous poster having ability to setup after router/network restart is likely related to this, since the 2.4ghz network comes online much faster than 5ghz on restart.

    Like 2
  • Luke Ramy I tried both options, but no cigar. Would you have other suggestions for me by any chance? I tried restarting the eero but it still did not add the Wemo :-((

    Like
  • I have this issue as well, but found a workaround:

    Used to be that WeMo devices required you to go into Settings, connect to the WeMo device's own wi-fi network, then launch the WeMo app. This 'legacy' method also works for newer devices (that ask you to scan the HomeKit code) and can be used as a workaround when the newer 'scan to connect' method fails.

    In fact, I used the legacy method today to reconnect a light switch and a smart plug that fell off the network and app after a firmware update.

    (Make sure to temporarily disable the 5Ghz network on your Eero before attempting the above.)

    Like
  • @foxpaws42 thanks for your suggestion, I tried your legacy method (switching to 2.4ghz included) but no cigar for me. Either the Wemo app crashes or it says incorrect password for my WiFi (which is not the case). Hopefully eero finds a way to make these devices work soon :-(

    Like
  • I’ve noticed that the wemo app crashes all the time regardless of what Wi-Fi. I think it is a wemo problem. The only issue I have is that the wemo devices keep falling off the Wi-Fi and not connecting. 
     

    Before I got eero, I had the wemo app crash on me random times. I used to disconnect from my Wi-Fi and access through cellular and that stopped it from crashing. I don’t think that works anymore. 
     

    im wondering if the app crashes when it has trouble detecting the devices. And there may be an issue with eero keeping the device on the network. 

    Like
Like1 Follow
  • 1 Likes
  • 1 mth agoLast active
  • 6Replies
  • 596Views
  • 5 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com