2

HP printer goes off-line unpredictably

It's a HP5530 and it used to always be available when connected to the Virgin Router (by wifi).  It connects easily enough to the eero system, but drops the connection after some period of time.  This is a nuisance because I have to go and reboot the printer every time I want to print (unless the next print job is within an hour or two of the last one.

Any suggestions? (I did do a search but couldn;t find any solutions).

Thanks

Mike

30replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello Mike,

    It seems that the printer is losing connection when it might be going to sleep. I looked over HP support and it does not look like your model of printer has a means of preventing the sleep status. I was also to find one other article from the HP support site that states there are some issues with connectivity when the HP printer is connected through a surge protector. I have included the link below for your review.

    https://h30434.www3.hp.com/t5/Printers-Archive-Read-Only/My-HP-ENVY-5530-keeps-disconnecting-fron-wireless-network/td-p/3300073

    Please let us know if this solved your issue,

    James Wilcox

    eero Support

    Like
      • MikeS
      • Mike5100
      • 9 mths ago
      • Reported - view

      James Wilcox Hi James.  Yes I saw that info about the surge protector but it's running direct from a mains socket.  

      The problem with the other point you make is that if I connect the HP5530 to the native wifi provided by the Virgin hub/router, then it stays connected even of it does go to sleep.  I need to get the eeros to behave the same way.

      Thanks

      Mike

      (PS - I am not running the virgin and the eero wifi's at the same time although when I did, it didn't cause any problems, so I may have to revert to that)

      Like
  • Hi,

    I have the same issue with my HP ENVY 4500 series printer. It has been rock solid on my previous wireless setup but having now moved to Eero a couple of weeks ago the printer connects when first powered on and then after a few hours is shown as disconnected in the Eero app and cannot be seen by Apple wireless devices on the same network. However checking the status on the printer it shows as connected and reports a strong WiFi signal! I have a fixed IP on the printer, a reservation for that same IP on the Eero network and IPv6 is turned off on the printer. I cannot connect to it’s web interface either when Eero shows it as disconnected - I guess that makes sense though. It is also connected by USB to an iMac and obviously still works with that.

    It seems a not uncommon issue on searching various forums but there doesn’t appear to be a known resolution. I think I plan to plug the printer into a WiFi controlled socket so that I can effectively power cycle it remotely as, on powering up it will then be available for printing for a few hours.

    Brian

    Like 1
  • That's a good idea Brian - I have a spare smart plug.  I got some emails from eero support saying they had looked at my system and reckon my eeros are too close together - I think they are saying that the printer doesn't know which one to connect to.  Doesn;t sound likely to me and because of the 2ft stone walls in my house if I move the eero units further apart they fail to talk to each other.

    Mike

    Like
  • If that were the case then how come the printer connects happily when it is first powered on, as presumably it would possibly see multiple identical SSID instances then. It’s a nuisance and a tad annoying but otherwise I’m very happy with my new setup.

    Brian

    Like 1
  • There’s a problem with my idea as I tried it out! The printer can only be turned on by pressing the on/off button on it so cycling the incoming power only results in it staying turned off ☹️.

    Brian

    Like
      • MikeS
      • Mike5100
      • 8 mths ago
      • Reported - view

      Bricroq ah yes of course.  I will try moving the eeros so that the signal strength from one of them is much stronger at the printer and see if the support team's suggestion makes sense.  Failing that I think I will just reactivate the wifi of my Virgin router and connect the printer to that permanently.

      Mike

      Like
  • Hi all,

    I'm new to the forum, but stumbled across this thread because I have exactly the same problem as that described by MikeS above:

    • I have a Virgin router, which was successfully and 'permanently' connected to my HP5530 for years.
    • I've now installed an eero and successfully connected the printer.  
    • When the printer is not used for more than a couple of hours, it loses the connection to the eero and only connects if you turn the printer wifi off and on.
    • This doesn't happen if I connect to the 'old' Virgin network; the printer happily stays connected and instantly operable.

    Question to MikeS : did you find a solution, other than staying connected to the old network or being happy to turn the printer wifi off and on everytime you want to print?

    Question to James Wilcox : is this an issue that eero will be able to fix?

    Thanks all...

    Like
  • I haven't bothered trying to fix it to be honest.

    Mike

    Like
  • I have the same printer and running into the same exact issue that Bricroq described. My printer is right next to the eero so there is a strong signal all the time.

    Like
  • I implemented a workaround for this problem which, as my Eero system is hanging off the output of my original ADSL router, does give me a way to print. I have set up a different Wifi network on the ADSL router to which only the printer connects. I then have to use the HP Smart app to effect my printing from my IOS devices by printing to an IP address, so it is nowhere near as simple as it should be using AirPrint. Given that the HP printers are happy to stay connected in a setup like that it seems to me that it has to be an Eero issue.
     

    I’d also note than when the printer was connected to the Eero network and had “dropped off”,  a wireless status report run on the printer indicated it was still allegedly connected with excellent signal strength but no Internet connectivity. This latter also caused HP to contact me, as I use the Instant Ink system, to say that I had to reconnect my printer to the internet so they could check my print usage and issue my bill. That was the straw that forced me in to the current position. 

    Like
  • Had a similar issue with an HP 8715 printer. I found the issue was a problem with the 2.4mhz band on my router (Not an AERO). In my case I reset the 2.4 band and it worked properely thereafter. Easier troubleshooting would be just to turn the 5mhz band off for a while and see if the problem goes away.  (this assumes 2.4 and 5 are operating with the same SSID and password). 

    Like

  • This works really well for us, thank you!

    Like
  •  I think they are saying that the printer doesn't know which one to connect to.

    Like
  • Just adding my voice to this - have precisely the same issue with a printer that never dropped its connection once before I switched to eero. 

    This combined with other eero issues has be very much regretting my purchase. 3 routers all distributed over wired back haul with worse performance than my 10 year old Apple gear provided…

    Like
    • Hello Jjdsyd ,

      Thanks for reaching out to us and welcome to the Community! I would like to help you troubleshoot this behavior if you are willing. Can you answer a few questions so I can get a better idea of what we're working with? When you setup your printer, did you connect it to your eero network while the 5GHz was disabled or does the printer connect to 5GHz? Are any other devices experiencing this behavior? Also, what model of printer do you have?

      Like
      • Jjdsyd
      • Jjdsyd
      • 1 mth ago
      • Reported - view

      James Thanks James. I did not disable the 5GHz network when I connected it (and I have done this a number of times of course). But, it only ever connects to the 2.4GHz connect. 

      The printer model is HP4630. No other devices do this. But, my entire network regularly (once a day at least)  drops its IP connection completely, despite router remaining connected at high speed. Take a reboot to reestablish.  

      Also, my 3 hard wired and 1 wireless eero do not play nicely with FaceTime on iOS. I get a clear picture followed by the video dropping out (my video out that is) and a “Poor Connection” message from FT. This despite having +100Mbps speeds and no issues with Zoom or Teams.  Strange and frustrating. (And if I toggle to 5G the video immediately comes back).  I am not saying this is related to the issue with the printer, but they both only occur with the eeros. 

      Thanks. 

      Like
    • Hello Jjdsyd ,
      I understand how frustrating this can be. I've listed some additional steps you can take to try and resolve this behavior as well below.

      1) Check the eero Labs features and disable them one by one and monitor your network so we can rule out any of those settings potentially causing problems with devices on your network

      2) Check the placement of your eeros. We usually recommend customer start out by placing eeros around 35-45ft away from any other eero and then move them closer only if the eeros themselves are getting bad signal strength. You wouldn't need to do this with the wired eeros, but spreading the wired eeros out can help reduce WiFi traffic and relieve other congestion behaviors that might be affecting your devices. The article below will walk you through our other placement guidelines.

      https://support.eero.com/hc/en-us/articles/207897393-Where-should-I-place-my-eeros-#:~:text=For%20a%20quick%20and%20easy,eeros%20out%20around%20your%20home.

      3) Check if your printer has a sleep mode. If it does, check with the manufacturer if you can disable it to test.

      4) It sounded like you have an upstream router to your eero network. That would put the eero network in a double NAT and could potentially be the cause of the periodic drops. If your eero network is in a double NAT try setting the upstream router to bridge mode or the eero network to bridge mode and see if that helps. You can also place the Gateway eero into the DMZ of the upstream router to test.

      If none of those steps work please reach out to us so we can troubleshoot further. I'll share a link below with the phone numbers you can call. However, if you would rather troubleshoot over email we can do that as well. I will also send you a direct message with instructions on how to get an email to me as well shortly.

      https://support.eero.com/hc/en-us/articles/207376426-How-do-I-contact-eero-support-

      Like
      • Jjdsyd
      • Jjdsyd
      • 1 mth ago
      • Reported - view

      Thanks James  I will respond directly to your email per your suggestion so as not to clog up the forum. But for anyone else’s benefit:

      1) all the Labs features are disabled

      2) the eeros are more than 50 feet apart (and wired)

      3) as discussed earlier in this thread the printer does have sleep mode but it be disabled and it should not drop the wifi connection (doesn’t AirPort Extreme)

      4) The Gateway eero is connected directly to the cable modem (there is no other router in between so no double NAT issue). 

      I afraid these are not the solutions to this issue. 

      Like
  • I too am having this problem with a HP P1102w. Worked fine before having EERO's :(

    Like
    • Hello MattHousley ,

      Thank you for reaching out to us on the Community! Lets start digging into this. What troubleshooting have you done so far with the printer? Just to make sure, your printer is connecting but then disconnecting from the network later correct? Did you try power cycling your eero network? Do you know if your printer has a sleep mode?

      Like
    • Hi James,

      Thanks for getting back to me.

      "What troubleshooting have you done so far with the printer?"
      The printer was originally set up for DHCP, but I've changed this to a static IP (reserving the IP address in the EERO IP Settings). This made no difference. 

      "your printer is connecting but then disconnecting from the network later correct?"
      Yes.

      "Did you try power cycling your eero network?"
      Yes. Problem remains.

      "Do you know if your printer has a sleep mode?"
      Yes, it's set to sleep after 5 minutes and to never power off.

      Cheers

      Matt

      Like
    • Hello MattHousley ,

      Thank you for the answers. Are any other devices experiencing this disconnect behavior? Lets try connecting your printer to the eero network and verify it is connected in the eero app. Watch the printer for the 5 minutes and when it goes to sleep please check the eero app and see if it dropped connection to the eero Network.

      Like
    • James 

      "Are any other devices experiencing this disconnect behavior?"
      No.

      "Lets try connecting your printer to the eero network..."
      The printer power light goes off after about 50 minutes (even though sleep is set to 5 minutes). It's stayed visible in the Eero app and available on the network (checked through the iOS App "HP Smart") for 20 hours now.
      I've got a feeling that checking to see if it's available regularily (which I assume issues a Ping or the like) must be keeping the connection alive...

      Thoughts? I'm happy to try anything else you suggest to help.

      Thanks

      Matt

      Like
    • Hello MattHousley ,

      What is your SSID name on your network? Does it have any special characters in it? If you continue to experience the disconnect behavior and your SSID has any special characters in it, that could also be the cause of the problem. If you do have special characters in your SSID, try removing them, reconnect the printer, and monitor it. If you're printer is staying connected now though, continue to monitor and let me know if the behavior comes back up.

      Like
    • James 

       

      The SSID is “TheTwilightZone” so no special characters.

      I’ll monitor and get back to you.

      Thanks

       

      Matt

      Like
    • Hello MattHousley ,

      Sounds good. Reply here if you continue to experiencing this behavior and we'll get a ticket started so we can take a look into the network and the logs on the backend.

      Like
    • James 

      I’ve just checked again, having not looked on the eero or HP app since posting my reply yesterday and it’s dropped off both.

      Let me know how you want to proceed.

      Cheers

      Matt

      Like
    • Hello MattHousley ,

      Alright. We'll want to get some time stamps of when the printer dropped offline and once you have those follow the instructions I will send you over direct message so we can get a ticket created and take a look into the logs.

      Like
    • James Thanks. Message sent.

      Like
Like2 Follow
  • 2 Likes
  • 2 wk agoLast active
  • 30Replies
  • 347Views
  • 11 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com