1

HP printer goes off-line unpredictably

It's a HP5530 and it used to always be available when connected to the Virgin Router (by wifi).  It connects easily enough to the eero system, but drops the connection after some period of time.  This is a nuisance because I have to go and reboot the printer every time I want to print (unless the next print job is within an hour or two of the last one.

Any suggestions? (I did do a search but couldn;t find any solutions).

Thanks

Mike

14replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello Mike,

    It seems that the printer is losing connection when it might be going to sleep. I looked over HP support and it does not look like your model of printer has a means of preventing the sleep status. I was also to find one other article from the HP support site that states there are some issues with connectivity when the HP printer is connected through a surge protector. I have included the link below for your review.

    https://h30434.www3.hp.com/t5/Printers-Archive-Read-Only/My-HP-ENVY-5530-keeps-disconnecting-fron-wireless-network/td-p/3300073

    Please let us know if this solved your issue,

    James Wilcox

    eero Support

    Like
      • MikeS
      • Mike5100
      • 4 mths ago
      • Reported - view

      James Wilcox Hi James.  Yes I saw that info about the surge protector but it's running direct from a mains socket.  

      The problem with the other point you make is that if I connect the HP5530 to the native wifi provided by the Virgin hub/router, then it stays connected even of it does go to sleep.  I need to get the eeros to behave the same way.

      Thanks

      Mike

      (PS - I am not running the virgin and the eero wifi's at the same time although when I did, it didn't cause any problems, so I may have to revert to that)

      Like
  • Hi,

    I have the same issue with my HP ENVY 4500 series printer. It has been rock solid on my previous wireless setup but having now moved to Eero a couple of weeks ago the printer connects when first powered on and then after a few hours is shown as disconnected in the Eero app and cannot be seen by Apple wireless devices on the same network. However checking the status on the printer it shows as connected and reports a strong WiFi signal! I have a fixed IP on the printer, a reservation for that same IP on the Eero network and IPv6 is turned off on the printer. I cannot connect to it’s web interface either when Eero shows it as disconnected - I guess that makes sense though. It is also connected by USB to an iMac and obviously still works with that.

    It seems a not uncommon issue on searching various forums but there doesn’t appear to be a known resolution. I think I plan to plug the printer into a WiFi controlled socket so that I can effectively power cycle it remotely as, on powering up it will then be available for printing for a few hours.

    Brian

    Like 1
  • That's a good idea Brian - I have a spare smart plug.  I got some emails from eero support saying they had looked at my system and reckon my eeros are too close together - I think they are saying that the printer doesn't know which one to connect to.  Doesn;t sound likely to me and because of the 2ft stone walls in my house if I move the eero units further apart they fail to talk to each other.

    Mike

    Like
  • If that were the case then how come the printer connects happily when it is first powered on, as presumably it would possibly see multiple identical SSID instances then. It’s a nuisance and a tad annoying but otherwise I’m very happy with my new setup.

    Brian

    Like 1
  • There’s a problem with my idea as I tried it out! The printer can only be turned on by pressing the on/off button on it so cycling the incoming power only results in it staying turned off ☹️.

    Brian

    Like
      • MikeS
      • Mike5100
      • 3 mths ago
      • Reported - view

      Bricroq ah yes of course.  I will try moving the eeros so that the signal strength from one of them is much stronger at the printer and see if the support team's suggestion makes sense.  Failing that I think I will just reactivate the wifi of my Virgin router and connect the printer to that permanently.

      Mike

      Like
  • Hi all,

    I'm new to the forum, but stumbled across this thread because I have exactly the same problem as that described by MikeS above:

    • I have a Virgin router, which was successfully and 'permanently' connected to my HP5530 for years.
    • I've now installed an eero and successfully connected the printer.  
    • When the printer is not used for more than a couple of hours, it loses the connection to the eero and only connects if you turn the printer wifi off and on.
    • This doesn't happen if I connect to the 'old' Virgin network; the printer happily stays connected and instantly operable.

    Question to MikeS : did you find a solution, other than staying connected to the old network or being happy to turn the printer wifi off and on everytime you want to print?

    Question to James Wilcox : is this an issue that eero will be able to fix?

    Thanks all...

    Like
  • I haven't bothered trying to fix it to be honest.

    Mike

    Like
  • I have the same printer and running into the same exact issue that Bricroq described. My printer is right next to the eero so there is a strong signal all the time.

    Like
  • I implemented a workaround for this problem which, as my Eero system is hanging off the output of my original ADSL router, does give me a way to print. I have set up a different Wifi network on the ADSL router to which only the printer connects. I then have to use the HP Smart app to effect my printing from my IOS devices by printing to an IP address, so it is nowhere near as simple as it should be using AirPrint. Given that the HP printers are happy to stay connected in a setup like that it seems to me that it has to be an Eero issue.
     

    I’d also note than when the printer was connected to the Eero network and had “dropped off”,  a wireless status report run on the printer indicated it was still allegedly connected with excellent signal strength but no Internet connectivity. This latter also caused HP to contact me, as I use the Instant Ink system, to say that I had to reconnect my printer to the internet so they could check my print usage and issue my bill. That was the straw that forced me in to the current position. 

    Like
  • Had a similar issue with an HP 8715 printer. I found the issue was a problem with the 2.4mhz band on my router (Not an AERO). In my case I reset the 2.4 band and it worked properely thereafter. Easier troubleshooting would be just to turn the 5mhz band off for a while and see if the problem goes away.  (this assumes 2.4 and 5 are operating with the same SSID and password). 

    Like

  • This works really well for us, thank you!

    Like
  •  I think they are saying that the printer doesn't know which one to connect to.

    Like
Like1 Follow
  • 1 Likes
  • 3 wk agoLast active
  • 14Replies
  • 147Views
  • 9 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com