0

eero 6 stuck at registering itself, need a quick workaround

Hi,

I just bought a 3-pack of brand new eero 6 which I thought would be easy to set up and paired with the local ISP modem here in Indonesia, Asia-Pacific region (more famously known for its paradise island of Bali).

But after two weeks of trying all the possible tricks I know, I'm so sad that the eero 6 is nowhere near usable and stuck at saying it encountered an issue without explaining it in details.

So here I am, hopefully someone can help me find a quick workaround to use the eero 6 cause I really wish to enjoy it not being frustrated in the process... I'll list the information below as concise as I could 👇

First information is about the ISP:

  1. it is Biznet.
  2. the modem is Huawei EchoLife EG8245H5
  3.   
  4. it's a fiber-optic (GPON) combo modem/router
  5. Biznet uses only PPPoE connection, no other connection is allowed, I've asked
  6.   
  7. the Biznet combo modem/router is already up and running, every devices connected to it can access the internet with IP Addresses being given by its DHCP feature.

Second information is how I set up the gateway eero 6:

  1. I turned off the ISP combo modem/router's Wifi by accessing its settings with my MacBook connected using LAN cable.
  2. I plugged in the gateway eero 6 LAN cable into its Ethernet port and plugged in the other end into the ISP combo modem/router's Ethernet port (yes, all of the Ethernet ports are active and can access the internet, I've checked it using my MacBook connecting to each Ethernet ports to test them out).
  3. I plugged in the gateway eero 6 power and waited until it was fully up indicated by the blinking blue LED.
  4. I opened the eero app on my iPhone, log in using my Amazon account, and successfully paired with the gateway eero 6 indicated by the solid blue LED.
  5.  
  6. My iPhone has LTE cellular connection, and during the setup it had great internet connection, I double checked it before starting with the eero setup.
  7. The eero app then asked me to name the physical location of the gateway eero 6, I chose Office.
  8.  
  9. Then the eero app asked to create a Wifi name and password, I happily obliged.
  10.  
  11. Afterwards the eero app shows it was trying to connect to the internet.
  12.  
  13. A second or two later the eero app shows it was trying to register the gateway eero 6.
  14.  
  15. This is where everything went ugly, the eero app says it found an issue and ask me to try again, but no matter how many times I tried it always stuck at that particular process (registering the gateway eero 6).
  16.  
  17. After retrying many time, I tried changing the ISP combo modem/router into the Bridge WAN mode, so I did try it only to found out that all of the devices connected through its Ethernet ports disconnected from the internet, including the gateway eero 6 (unfortunately I didn't take a screenshot of the eero app saying that the gateway eero 6 doesn't have internet access). So I had no choice but to turn it back into Route WAN to restore the internet connection online again.
  18.  
  19. Unlike many other users who have testified in this community where they turned the ISP modem into Bridge mode and then successfully installed the eero, this Biznet combo modem/router doesn't work like that at all.
  20. The same thing goes for the Wifi connection in the Biznet combo modem/router, other users testified in the community that simply by turning off the ISP modem's Wifi made the eero installation successfully work. That does not apply to the Biznet combo modem/router...
  21. I've tried many times restarting both the Biznet combo modem/router and the gateway eero 6 before trying out with the setup again, but it still stuck at the same process.

The third information is about setting up double-NAT as another effort to make it work:

  1. I use TP-Link C54 router, it has WAN Ethernet port and 4 Ethernet ports, I set it up as a router with different IP Address poll than in the Biznet combo modem/router, its DHCP is turned on too.
  2. I plugged out the gateway eero 6 LAN cable from the Biznet combo modem/router's Ethernet port, and then plugged it into the TP-Link C54 Ethernet port (yes, all of the four ports already configured to have access to the internet, I've set it up and tested it out before hand, don't fret).
  3. Then I used another LAN cable to plugged in one end into the Biznet combo modem/router's Ethernet port, and the other end into TP-Link C54's WAN port.
  4. Before starting with the eero app setup again, I restarted all of them once again, waited until all are fully boot up and ready, and waited until the gateway eero 6 blue LED was blinking.
  5. I started the eero app setup once more, only to reached to the same conclusion: eero app said it found an issue so it failed to finish the setup.

I've run out of ideas, I hope someone know another method to make it work. I really want to like the eero 6, I really do, but this set back is a huge bummer. I thought eero can work its magic even for me who live in Indonesia...

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • What is the reason why you did step 1 "I turned off the ISP combo modem/router's Wifi "?

    Like
      • andy_ID
      • espresso addict
      • andy_ID
      • 12 days ago
      • Reported - view

      J Alfred Prince just for the kicks of it, because I read in few solutions posted by other eero users that they successfully connected the eero to the combo modem/router by turning off its Wifi.

      I know that is silly, the combo modem/router Wifi won't affect the gateway eero 6 from connecting to the eero cloud service, it can only affects or interrupt eero 6 Wifi if the SSID name configured the same.

      But hey, I'm desperate here, I'll try anything no matter how silly it is as long as it works.

      Like
Like Follow
  • 12 days agoLast active
  • 2Replies
  • 29Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com