0

Can’t connect Brother HL-L3290CDW printer to eero. Any ideas?

I just upgraded to eero and everything seems to be working great but my 1 year old brother printer won’t connect for some reason. I’ve tried downloading the setup wizard on my computer and also manually inputting my router name/password in the printers menu. It worked fine with my old spectrum internet router. Thanks in advance 

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello Fcovey ,

    Thank you for reaching out to us and welcome to The Community! There could be a few things that are the cause of this behavior. Do you have eero 6 or eero Pro 6 as your network? If so, it could be that your printer does not support WiFi 6. You can turn on legacy mode by going into Settings -> Troubleshooting -> My device won't connect and you will see the options in here to turn on Legacy mode. You may also need to temporarily hide 5GHz as well as most printers can only connect to 2.4GHz networks. You will do this in the same section. Settings -> Troubleshooting -> My device won't connect and you will see the option that states your device is 2.4GHz only.

    Try those options above and let me know if you are still experiencing difficulties.

    Like
Like Follow
  • 1 mth agoLast active
  • 1Replies
  • 11Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com