Issues using eero with OpenDNS

For weeks I kept trying to get OpenDNS to work properly with eero. I entered the IPv4 and IPv6 OpenDNS server IP addresses into eero and all seemed good. But when I using the OpenDNS test of "welcome.opendns.com" I would get errors that I was not using OpenDNS. Then I changed the DNS settings on the computers (Mac and Windows) to manual instead of automatic and entered the OpenDNS server IP addresses into each Desktop/Laptop. That sort of worked as some brewers would state it was using OpenDNS and other browsers would give the error that I am not using OpenDNS. 

Then I went into the eero app and turned off Advanced Security and Ad Blocking. That did the trick as all browsers and connected device started saying I was using OpenDNS....problem solved.....sort of as now I cannot using Advanced Security and Ad Blacking. 

So WTH is the issue with eero Advanced Security and Ad Blocking that prevents the OpenDNS servers from being used?

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Because if you have advanced security and ad blocking enabled, eero is overriding your manual DNS settings and using their own to route your DNS traffic through their 3rd party service provider that handles the DNS filtering.

  • Well that is a bummer. No sense paying extra for security now if you cannot use it.

      • Melissa69
      • Melissa69
      • 2 mths ago
      • Reported - view

      jduffy You are right. There is no sense paying extra for security now if you cannot use it.

      Fragomen Connect Portal

Like Follow
  • Status Answered
  • 2 mths agoLast active
  • 3Replies
  • 30Views
  • 4 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support