Stuck on "Looking for Eero devices..." Bluetooth

Looking for some help from the community regarding Eero setup. After replacing my Spectrum modem, my Eero network would not come back online. So, I deleted the network from my Eero app entirely and hard-reset the gateway Eero and unplugged my second Eero. Despite many, many attempts, I cannot get the app to move on past the "Looking for Eero devices..." screen. The Eero light does turn solid blue, indicating a pair but the app never progresses.


Things I've tried:

  • I've tried hard-resets, no avail
  • I've connected the ethernet from my modem straight into a computer to confirm internet is live and working
  • I've tried setting up both Eero's as the gateway, neither moves past the same spot referenced above
  • I've tried three different devices with the app, two iPhones and one iPad
  • I've tried turning off bluetooth and wifi and waiting 
  • I've tried deleting and reinstall the Eero app
  • I sat on the phone with Eero this weekend for over an hour and they tried to "push" a new network configuration to my Eero, that did not work

I am running out of ideas here. I tried to call Eero today but sat on hold for an hour and had to move on to other things in my schedule. I bought a cheapo Netgear router from best buy to get me through until my Eero's are fixed. But I have to say that for a premium product, my experience has been totally abysmal. I installed Eero's at my parents house before they were purchased by Amazon without issue. So, I thought I'd do the same at my house and bought the 2-pack maybe 3 or 4 months ago now and I am starting to regret my decision.


Any tips would be greatly appreciated. I just want to get the Eero's back working.

35 replies

    • rtkramer
    • 1 yr ago
    • Reported - view

    Having this issue, iPhones, reset, errors will not move past looking for gateways, solid blue light, I am getting ready to take erro back and just get whatever, I actually like the mesh service but 1 whole year of people having this issue and no fix 👎🏻 Eero

      • eero_support
      • 1 yr ago
      • Reported - view

      Hello rtkramer ,

      Thank you for reaching out to us regarding this behavior you are experiencing. I understand that this is quite frustrating and would like to help you get your network back up and running if you still need assistance. I will send you a direct message on how we can proceed as I will need to get access to and verify your account for security purposes to look into what is happening with your eeros.

    • donmccarty
    • 1 yr ago
    • Reported - view

    Just received a 2-pack of pro 6E.

    First one set up as expected, no problems.

    Second one is doing what is described here.  iOS v15.5 -

    As of right now - DOA out of the box
    I have to keep it up to date for work so caught between a rock and a hard place.

    Charging an old iPhone to see if I can get it to work there.

    • Edentoomuch
    • 1 yr ago
    • Reported - view

    I recently ordered a pair of eero 6+ and am running into the issue described here. The first device paired as expected but the second one can't be found. I've sent an email to the customer support team. I'm not sure if I should just ask for an exchange through the amazon website. 

    • Jonf316
    • 1 yr ago
    • Reported - view

    I had this issue a while back - it started around 4 months after I set up my Eero pro system with 3 units.  Had multiple messages with support and went through multiple rounds of powering down the system / re-siting the units etc.  to no avail.  Support wanted to set up a video call to review my setup but as I was due to be moving house I suggesting waiting.  

    Once I moved, I tried the unit again in case it miraculously worked, but it didn't.  I did however have a brainwave and tried something not previously suggested - I connected the faulty unit direct to my router and added it as a new network - lo and behold it found the unit, connected and downloaded the latest updates.  Once this was complete, I removed the new network and tried to add it to my existing network and Success!

    So whilst I do not know the root cause, I suspect it is related to a faulty software update, resolved by setting up a new network to download a new update

    • BMcDowell
    • 10 mths ago
    • Reported - view

    Wish I had seen this before buying the eero 6.  Having the same issue including on hold for an hour with no response.  Have an android  but that doesn't seem to matter.

    Any clues!?

    • oatley
    • 9 mths ago
    • Reported - view

    I know this is a really old thread, but I was having this issue as well, but I managed to resolve it.

    1. I unplugged my initial eero device from the modem.  Only connecting it to power.

    2. Used the app to try to set up a new network, where it normally got stuck on the "Looking for eero devices..."  Now, after waiting for it to search for new devices, it eventually times itself out and asks for a serial number to set it up.  It would NOT ask for this serial number if it was plugged into the modem or into another router.

    3. After plugging in the serial number, it came back with, "Found an eero device."  It then let me begin configuration.

    4. Once I set up my local WiFi information, I plugged it into the modem and restarted both.  The device then worked properly and I was able to add other eero devices normally.

      • dschimm
      • 8 mths ago
      • Reported - view

      oatley After 2 frustrating hours, this is LITERALLY the only solution that worked.  Felt it was important to take the time to create a log in (now subjecting myself to Eero spam) so I can respond to this thread, hopefully letting others know of a potential solution.  I consider myself reasonably tech savvy, but this has been absurdly difficult.  

    • Kasper
    • 6 mths ago
    • Reported - view

    Hi, so I recently moved broadband to different provider and they sent me this eero6 hub. I tried to connect with it for the past 3 days, used 3 different phones (all android) and it seems I'm not getting anywhere. I tried method @oatley mentioned but even when I get to the stage when it let's me  type the hubs serial number it comes up with message saying unable to connect and two options "try again " or "contact support " which I tried but again I haven't got hours to wait in queue.  Any ideas? 

      • Michael_eero_support
      • 6 mths ago
      • Reported - view

      Hi Kasper 

      Try unplugging both the eero and the modem from power for at least 3 minutes, plug the modem back in first, wait for it to boot and then the eero.  If that doesn't get the eero to function try swapping from modem->eero to modem->testing devices.  Something like a laptop, desktop, Playstation/Xbox, Smart TV, anything that has an ethernet port so you can hardwire it to the modem and can access the internet, make sure the modem is actually putting out internet via that cable.  If it doesn't, call the ISP.

      If it does your best option is to call into support so we can check into that eero.

Content aside

  • 6 mths agoLast active
  • 35Replies
  • 6546Views
  • 26 Following