Asking for a WPA2 username

I’m trying to revive an old Mac Mini that’s on Mountain Lion OS.  I had no problem joining my old WPA2 WiFi network. But when I tried to join my new Eero network, instead of just asking for a password, it says it requires WPA2 enterprise credentials, which has a password AND a username.

My understanding for forum posts is that Eero doesn’t support WPA2 enterprise, so why would the computer think that Eero is using WPA2 enterprise? Would anyone have suggestions on how I could get this computer to work with the Eero network?


3 replies

    • cMoo92
    • 3 yrs ago
    • Reported - view

    Do you have WPA3 enabled on your eero network? If so, disable that.

    • spunoza
    • 3 yrs ago
    • Reported - view

    That solved it. Thanks!

    • Andyokney
    • 2 yrs ago
    • Reported - view

    Worked for me too, WPA3 needs to be turned off for older operating systems

Content aside

  • Status Answered
  • 2 yrs agoLast active
  • 3Replies
  • 676Views
  • 3 Following