0

connecting hardwired devices via a switch

I used to have a netgear router and just switched over to an eero 2nd gen.   I have a few devices that are hardwired (my mac mini, an unraid server, smartthings hub, etc).

my new setup:

I have my cable modem connected to one of the ports on the eero and a netgear 5 port switch connected to the other port on the eero.

my hardwired devices are plugged into the other ports on the 5 port switch.

 

problem:

ever since switching things over to this configuration, some of my devices will not connect.

whats interesting is that a few of them connect with no problem.

My smartthings hub and my hue bridge connect with no problems.

My mac mini connects to the eero and I can see it as a hard wired device in the list of devices in the eero app, but I am unable to connect to the internet from my mac mini.

my unraid server is connected to the switch and does not even appear at all on the list of devices in the eero app.

how can I get the mac mini and my unraid server to connect properly?  any ideas would be appreciated!

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi blairdee2000 —

     

    Thanks for reaching out! Sorry to hear you're running into this issue with certain devices not working while hardwired; let's see if we can get it sorted out!

    In your Mac Mini, Go to System Preferences -> Network.  Click on 'Advanced' and select 'TCP/IP.  Click on the 'Renew lease' button. 

    Could you also try swapping cables and ports on the devices and the switch to double check that it's not an issue with those? 

     

    Thank you!

    Reply Like
    • Joey C. thanks for your response -sorry it took me a while to respond.  I thought I had actually gotten my issues worked out.  On my mac I had to go to the network preferences and under locations, add a new location.  after doign that it connected right up.

       

      my unraid server was set to pull a static IP address which differed from the address range that th eero was handing out.  

      so my devices are connecting now.

      Reply Like
  • Which switch are you using? Is it a managed switch, or unmanaged?  If it's managed, there have been issues with those and eero.

     

    If it's unmanaged, well....

    Reply Like
reply to topic
Like Follow
  • 3 mths agoLast active
  • 3Replies
  • 280Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com


Latest from the eero blog

IPv6 is here!