Clone MAC Address

Is there any chance that an option to clone a MAC address on the WAN port will come in the future?  I'd like to remove my ISP's "gateway" equipment from my network, but the only way to do this is to clone the gateway's MAC address to whatever router I'm using - which happens to be eero.

10replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Old feature request, but one I would also like to bump as it's required with AT&T Fiber to allow the eero to be the actual gateway and not just a pass-thru target.

  • Another eero user that wants to bypass the BGW210 fiber gateway that AT&T makes me use. Can't do that without being able to spoof the BGW210 MAC Address on the eero.

  • I'd love to see this too as I'm having NAT issues using my Eero with AT&T Fiber even when using IP Passthrough.

      • MrDoh
      • MrDoh
      • 3 yrs ago
      • Reported - view

      LiamBates Curious what issues that you're having with NAT with AT&T Fiber and eero, since I also have both of those. As far as I can tell my NAT is working fine. It may be that you have turned on IP Passthrough, but it isn't working. What is the "External Address" that you see in your eero app? That should be a real WAN address, not a 192.168.0.x type address. If you're seeing NAT from the fiber gateway rather than from your eero, or not seeing a WAN address in "External Address" in the eero app, go into the eero app, and look at details of the gateway eero node ("Advanced"). There are a couple of MAC Addresses there. The one that you need to use for IP Passthrough mode is the one that corresponds to the port that the fiber gateway is connected to. Look at the eero gateway node from the back, and pick the "left" or "right" MAC Address for the eero for IP Passthrough use according to whether the fiber gateway is plugged into the left or right ethernet port; e.g. if you've got the fiber gateway plugged into the left ethernet port on the back of the gateway eero node, then use the "left" MAC Address in IP Passthrough configuration on the fiber gateway.

      Hope this helps. If it doesn't, I'm still curious what issues you're seeing with NAT.

    • MrDoh I ended up bypassing the AT&T gateway with an edgerouter with eap_proxy and placing our eeros into bridge mode. For us, the AT&T gateway would begin to slow down every 3-7 days (random times) where our network would slow to a crawl (~2 minutes of no activity, then suddenly works for 15 seconds, then stops again). Rebooting the AT&T BGW210 fixed it every time. The NAT tables never filled (hit ~5,400 sessions tops), but even with far less sessions, it still would stop working after a period of time. To me, it very much felt like a memory leak in the router's software.

      Since bypassing their router completely, the problem has not returned. I imagine if I wasn't doing as much with our network (I run a hypervisor with lots of tiny VMs, some of which host services online), the BGW210 would be perfectly fine.

      • MrDoh
      • MrDoh
      • 2 yrs ago
      • Reported - view

      tsuehpsyde Already have the eero in AP mode, connected to an Edgerouter 4. I've given some thought to bypassing the BGW210, I have the right stuff to do that, but it hasn't given me any problems as yet. Other than eating some of my internet bandwidth. I'm finding 850-900Mbps to be fine for me, Don't really need the extra 40 or 50Mbps that I might get if I bypassed the BGW210.

      The worst part about the BGW210, it turns out, is that it is nailed to AT&T DNS. You can't change DNS servers on it. So AT&T is seeing everything that you do, no choice there. To give myself an illusion of privacy, I'm using NextDNS, that gives me DNS over https (encrypted DNS). On the other hand, AT&T sees everywhere that I go anyways, since they're providing the vehicle for my getting there. I trust them to sell whatever information about them that they can, they're pretty money-hungry these days.

      The other things I found about the BGW210 are just annoying, like it leaves the wireless radios enabled in IP Passthrough mode. And you can't turn off DHCP on the BGW210, even if you're not using it, you lose connection to the internet if you do that. Nice piece of work there. Hasn't gotten in my way enough to bypass it yet, though.

  • +1 on this. My ISP locks DHCP to modem’s MAC and there’s just no way without MAC cloning to get this to work properly, so have to use eero on bridge mode and router as the main gateway. I’m actually shocked this isn’t exciting feature, tp-link suggests MAC cloning during standard setup wizard on their routers.

  • Please make this feature available. 

  • How is this still not a thing?

    Like 1
  • Definitely a great feature to make eero my main gateway at home and remove the default Epic Malta router.

Vote13 Follow
  • 13 Votes
  • 5 mths agoLast active
  • 10Replies
  • 714Views
  • 9 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support