Latest Software 6.4.0

Anyone else noticing that wifi is disconnecting frequently after this recent software update to 6.4.0?

73replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Getting timeouts as well, diagnosed it yesterday. Perhaps has been happening for a month or more, as have had weird internet glitches for that long. This is not a placement issue, everything is optimal, and all eeros are connected to each other via cables. Anything connected to the eero network (linux, mac, windows) has this timeout issue simultaneously (tested wired and wireless), whereas anything bypassing the eero network and connecting directly to the modem does not. Abysmal template responses here from Eero. Have your engineering department provide your support.


    Other debugging steps we've tried:

    1. toggling eero settings

    2. replacing cables

    3. replacing switches

    4. testing wifi and wired

    5. adjustments in case of overheating or dust

    6. testing different dns


    Debugging steps still to try:

    1. Ipv6 mode, that was mentioned by another user here

    2. changing the eero dns server to the modem's ip

    3. adguard dns server connected directly to the modem, that the eero can then leverage for dns

    4. swapping the gateway/router eero (the one that plugs into the modem) with one of the other eeros, in case the main eero has become faulty


    it would be ideal if we could also try downgrading the firmware


    If anyone also has good cross platform monitoring software recommendations that would be good, right now windows hard fails however macos and linux seem to wait upon these failures to resolve, so we are using ping commands with appropriate environment specific flags to monitor. 

      • map55555
      • map55555
      • 1 yr ago
      • Reported - view

      balupton I experienced exactly the same.  Have had numerous visits from my ISP too to confirm it wasn't a line issue.  Swapped out the modem for a new one, replaced cables and bought a new eero pro.  Problems persisted.  Noticed that the problems started to subside somewhat after the recent system upgrade from 6.4 to 6.5 but then the problems came back again; however, the recent system upgrade to 6.5.1 seems to have caused the problems to subside again.  FYIk I did notice that the problems don't resolve themselves immediately after the software upgrade but take a day or so. Fingers crossed this works this time.  

      • balupton
      • balupton
      • 1 yr ago
      • Reported - view

      balupton map55555 I was able to get it working a week after my last post by disabling all features and setting the DNS to a AdGuard Home server running on a Raspberry Pi. 

      However, running the lastest system update, I am using an external DNS and not the local AdGuard Home server on the Raspberry Pi, and it seems to be working fine. Perhaps they have resolved it.

  • How do I check what version software I have?

  • Open the app  Settings/software updates/ 

  • Our Orbit B-hyve controllers at two different houses, both on eero networks, will no longer connect to wifi.  Orbit even sent us new boxes to try, same result.  Both connect just fine to neighbors non-eero networks.

Like9 Follow
  • 1 yr agoLast active
  • 73Replies
  • 1233Views
  • 30 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support