1

MyQ garage door opener won't pair with eero

I am trying to connect my Chamberlin MyQ garage door opener to eero.

I was not able to get it to work via bluetooth, so I tried connecting the the webserver on the Hub ( setup.myqdevice.com ).

There it offers me three different connections for each of my primary and guest network. I have tried all 6 of them with WPA2-AES as the encryption.

The device will not pair with the eero not matter what I try. This is an older model MyQ, is this device known not to work with eero? It worked great with the most recent Airport Extreme tower that Apple made, so I am surprised it won't connect with eero.

44replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I have the original MyQ and it works fine with eero.

    Like
  • I had to fiddle with the app of my new opener to get it to connect. Had to choose another type opener from the list of 3 or 4. 

    Like 1
  • I know in the past I've seen posts similar to this. It's usually because the device is 2.4Ghz only and they can sometimes struggle with connecting. Best bet is to contact eero support. I know they'll be happy to assist.

    https://support.eero.com/hc/en-us/requests/new

    Like 1
  • I tried all the directions in the Chamberlain directions and none worked either to reconnect Eero wifi to the opener.  Finally had to hold the wifi blue blinking light for 5 to 10 seconds until hear a beep which erased previous wifi.  Then went through the set up and it worked finally.  In all of Chamberlains descriptions, they dont state to do this.  They talk about hitting the yellow button 3 times to turn on wifi or go through the contol on wall to start wifi mode. When doing this, it didnt connect until cleared the unit by holding down blinking wifi button.  Hope this helps. 

    Like 4
      • cotedan87
      • Fan of tinkering with new hardware. Canadian dude.
      • cotedan87
      • 2 yrs ago
      • Reported - view

      Tvlas good to know. THanks. 

      Like
      • kvwong
      • kvwong
      • 2 yrs ago
      • 2
      • Reported - view

      Tvlas Came here to say this worked for me. myQ garage opener dropped off after adding an Eero Pro to the downstairs even though it was working fine previously. I tried all of the steps and worked closely with Eero customer service (bless them) to no avail. Can't believe I missed the blue blinking reset. Thank you.

      What bothers me is that I did a factory restore (holding the yellow button) and that didn't achieve the same results. Also what bothers me is that Chamberlain customer support flat out said Eero isn't compatible/supported. Disappointed in their training and help experience. 

      Like 2
      • bmw325ia
      • bmw325ia
      • 1 yr ago
      • 1
      • Reported - view

      Tvlas Thank you for the tip of holding down the blue button and hearing the beep three times finally did the trick for me after trying unsuccessfully 20 times the instructions by myq app

      Like 1
      • Tvlas
      • Tvlas
      • 1 yr ago
      • Reported - view

      bmw325ia Glad it worked! Went through the same frustrating thing too!.  

      Like
    • Tvlas these instructions also worked for me. Thank you 

      Like
      • Tvlas
      • Tvlas
      • 1 yr ago
      • Reported - view

      bdellecese Glad it worked!

      Like
      • Pdean0
      • Pdean0
      • 1 yr ago
      • Reported - view

      Tvlas Thank you!  Worked!

      Like
      • Tvlas
      • Tvlas
      • 1 yr ago
      • Reported - view

      Pdean0 Your Welcome!

      Like
      • Jplace
      • Jplace
      • 1 yr ago
      • 1
      • Reported - view

      Tvlas you are a genius. Thanks for the insight! I held the blinking blue button for 10 seconds and the unit beeped several times. I then started the myQ setup from the beginning by pushing the learn (yellow) button three times and moving on from there. Thanks again.

      Like 1
      • Tvlas
      • Tvlas
      • 1 yr ago
      • Reported - view

      Jplace Happy to help! Have a good one! 

      Like
  • Glad it worked!  Good information that the factory restore didn't even work and that Chamberlain wasn't any help. That's what these forums are for! Thanks for the update! 

    Like 1
    • Tvlas  

      Like
    • Markdkingcpa. I have same problem but blue wifi reset will not work for me.  I feel like i have tried everything including being told by Chamberlain Eero is not supported.  Does anyone have any other ideas or more detailed instructions?

      Like
      • kvwong
      • kvwong
      • 2 yrs ago
      • Reported - view

      Markdkingcpa prior to resetting the WiFi config via blue button, I removed the garage door from the myQ app, factory restored the unit and soft reset Eero devices. 

      Like
      • Tvlas
      • Tvlas
      • 2 yrs ago
      • Reported - view

      Markdkingcpa 

      Did u hear the beep when holding down the blue wifi button? That means it reset.  Go through the wall unit to then hear the beep to start the process for reconnecting the wifi.  Your phone has to be on the same wifi you are trying to connect to and make sure to have a strong signal. Make sure your phone is connected to the closest Eero unit to the garage door opener  if have more than one.    Have your phone next to the Chamberlain garage door opener when trying to connect it  and follow the directions on the My Q app.  Could try calling Eero also as they have been helpful per kvong note, but did not suggest the blue wifi reset.  

      Like
  • Tvlas's blue-button trick worked for me. Happy camper. :)

    Like 2
  • Same here, tried 15 times, not connecting, blue light kept blinking. Then read this thread. Tvlas was right, holding down the blue button for 6 seconds did reset something and then blue light stopped blinking, then started over again, and it connected.

    Like 1
      • Tvlas
      • Tvlas
      • 1 yr ago
      • Reported - view

      Desmondh Glad it worked for ya!  

      Like
  • I cant believe that I am like the rest of you and didn’t hold down the blue flashing button to reset it. Hahahahaha thanks to all of you! Drove me NUTS....

    Like 1
  • You need to have your phone connected to 2.4ghz Wifi. I unplugged nearest Eero unit which forced my phone to connect to Eero unit farther away from garage, and allowed me to finish setting up MyQ.

    Like
      • Dnasep
      • Dnasep
      • 1 yr ago
      • Reported - view

      I found a better solution for connecting to 2.4GHZ wifi.

      In the Eero app

      Click settings at the bottom right corner

      Click Troubleshooting

      Click My device won't connect

      Click Temporarily pause 5GHz button

      You are now on 2.4 GHz channel of your Eero for about 15 minutes to add your device.

       

      Do the steps needed to connect your device while on 2.4 GHz wifi.

       

      If you are done adding device before time runs out, click Cancel in Eero app to re-enable 5GHz.

      Like
  • If the above hasn’t worked for you with the latest updates I was going crazy until I paused 5ghz like the above and turned off WAP3 under eero labs. 

    Like 1
      • Jh7684
      • Jh7684
      • 11 mths ago
      • 3
      • Reported - view

      Fosterj this worked for me: reset myq device, troubleshoot device with eero to switch to 2.4 ghz, and then turn off wpa3 in labs (which is a different area of the eero app). The symptom of the wpa3 issue was the wifi password prompt never appeared, even when the blue light was flashing. Thank you for this, it was very helpful!

      Like 3
      • jlhomme
      • jlhomme
      • 4 mths ago
      • Reported - view

      Fosterj Finally worked after following the steps above to restrict eero to 2.4 GHz and turning off WPA3.  Thanks everyone!

      Like
    • Jh7684 it was turning off WPA3 that finally fixed it for me. Thanks!

      Like
  • Glad that works.  When the thread first started, Eero didn't have the option to turn off the 5GHz channel and didn't have WAP3 option yet.  Still might need to hit the blue wifi button to reset is what I'm thinking along with also pausing 5GHZ on Eero.

    Like 1
  • Got the new Eero pro Wifi 6 router.  When replacing router, had to reset garage wifi again.  Used the troubleshoot on the Eero router as above to keep on 2.4 GHz and it worked.  Just need to make sure when change to 2.4, you need to make sure your phone is connected into the 2.4 wifi also.  Needed to put my password in again to connect to the 2.4 on Samsung phone.

    Like
  • Mine stopped working if I enabled the WPA3 option under Discover/eero labs section. Seems to still work if I just have band steering enabled however

    Like 1
  • Same here.  Just upgraded to an Eero 6 Pro and it won't connect.

    Like
  • MyQ Garage Hub all of a sudden would not connect again with Eero after factory reset. I had to reset it to pair again with  Homekit Hub.  After resetting many times still wouldn’t connect to Eero.  I even tried MyQ web based set up and nothing.  Solution:   I disabled WPA3 in the Eero App and Bingo it connected right away after a final attempt.  Hope this helps others. 

    Like
  • I have been offline for a week. Eero 6 has IPv6 available now and it's not compatible with MyQ. I changed it back to IPv4, set encryption to WPA2, Temporary 2.4 Ghz set, and nothing. Resetting the  black button and attempting to connect with a laptop were also not helping. Support has not been helpful. 

    Like
      • txgunlover
      • txgunlover
      • 7 mths ago
      • Reported - view

      vfreidin That is so weird.  Mine works fine.

      Like
      • wase4711
      • wase4711
      • 7 mths ago
      • Reported - view

      txgunlover if your devices is NOT WPA3 compatible, and many many devices are NOT< then do NOT use WPA3..

      seems so logical...

      Like
  • Hi All. Lots of success for some people here, but I am unable to get MYQ to connect after using the blue reset on the garage unit , unplugging all eero mesh devices except the router, disabling WPA3, IPV6, temporary 2.4ghz. etc. I am baffled. I can get the MyQ to go through the routine of set up, with all of the beeps/confirms showing on the app, and it even shows in the eero app as being connected, but when I go to use the MYQ app it shows no devices . I have probably been through some variation 20 times? Any other thoughts? I have even thought about using a dedicated 3rd extender just for the MYQ at this point. 

    Like 1
    • kcole5 do you have any special characters in the name of your network? Basically anything but letters? If so, try renaming your network so it’s just letters and see if that fixes the issue.

      Like
      • kcole5
      • kcole5
      • 7 mths ago
      • Reported - view

      Thank you for the suggestion. Unfortunately my network name is just letters. No special characters 

      Like
  • I think the answer to the connection problem is this: The network detection of a wifi 6 network (that's a thing), is not feasible by MyQ.  So, we need to dumb the network down to 2.4Ghz, the MyQ will find it and register the wifi.  Then, we'll get eeros back to 5Ghz and restart the MyQ.

    Here's how I got mine to connect:

    1. In eeros app, Troubleshooting>>Device wont connect>>Temporarily Place Network on 2.4Ghz (for 15 minutes)
    2. Unplug the MyQ Garage Hub (in my case)
    3. Plug it back in 
    4. The MyQ Hub will flash green and blue lights
    5. Hold the left most button (Reset) on the MyQ Hub, until you get a flashing blue light
    6. With a flashing blue light, open MyQ app on phone
    7. Login to the MyQ-NNNN network
    8. You'll see your SSID (eeros wifi network)
    9. Now, you're connected.  BUT, eeros is on 2.4Ghz.  Cancel out of the 2.4Ghz in the eeros app
    10. Unplug/Plug in the MyQ Hub (it'll run fine on 5Ghz.  it just couldn't see the network on 5, only on 2.4)

     

    note: you might have to restart the printer and other appliances on the eeros network, since you flip-flopped the 5 to 2.4 to 5 schtick.
     

    Like
  • I finally managed to get mine to work by resetting the opener back to factory settings, shutting down all eeros except the main one, temporarily setting my network to 2.4 and going through the set up routine again following the myQ instructions. Maybe it was dumb luck but it has been up and running for a few days

    Like
  • Tvlas Thanks for your suggestion.  I had given up on connecting myQ and when I read your instructions.  I have it working.  I am not sure if it was the reset or forcing my phone to connect to the same eero.  I am glad it's working.  Thank you!

    Dnasep Thank you for showing how to force a 2.4 GHz connection temporarily.  This will help many of the devices.

    Like
  • The person who suggested pausing the 5ghz and then turning off WPA3 did the trick for me.  Pausing the 5GHZ alone didn't work, but as soon as I turned off WPA3 it worked - finally!  I have spent two to 3 hours trying all the other suggestions and this was the only one that worked!

    Like
Like1 Follow
  • 1 Likes
  • 2 days agoLast active
  • 44Replies
  • 2848Views
  • 28 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com